Ford Powerstroke Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter #1
Just got my truck back from putting in a new OEM oil cooler, along with BPD EGR cooler, studs, etc etc etc

My tech did both flushes, filled with ELC, everything by the book.

Driving home around 70mph, coolant stayed between 188-192, oil between 200-205, deltas ranged from 8 to 17.

Fan clutch is dead, and I was running Looney (not wild). Not running hard, and unloaded. mostly level, very mild grades up and down.

I know this isn't exactly the "test" for deltas, but I always hear people saying they never ever ever see more than 8*

Any input?
 

·
Registered
Joined
·
167 Posts
Discussion Starter #3
i supplied the cooler, didn't realize clutch was toast until truck was put back together and road testing everything. hit some grades and ECT hit 220-230 briefly.

is 8-17* acceptable, unloaded, say at 70 mph?
 

·
Registered
Joined
·
2,003 Posts
Fix your fan then redo the test I have not heard of a bad Ford cooler out of the box I'm sure it has happened but haven't heard of it yet
 

·
Registered
Joined
·
167 Posts
Discussion Starter #5
Fix your fan then redo the test I have not heard of a bad Ford cooler out of the box I'm sure it has happened but haven't heard of it yet
wouldnt the ECT be high with a bad fan cluth?

should i replace it with stock, or convert to 7.3?

also, i read in another thread awhile ago that someone showed a pretty big variance with their SCT or Edge vs. AI or similar.... which if that were the case... my deltas were never really that bad haha.

Would hate to have all this $$ in my stupid livewire and end up having to add a couple gauges to monitor deltas more accurately.
 

·
Super Moderator
Joined
·
5,948 Posts
Stock or 7.3 doesn't matter, you need to fix that issue...

You will run all kinds of strange numbers until that fan is doing its job. It isn't just a matter of pulling air, that fan keeps a consistent air flow through the radiator. The spaces between the condenser, intercooler, and rad create dead spaces where air doesn't flow well. Much like behind the cab on your truck there is a low pressure zone, you get that in between all of those layers as well. As things heat up and need more air flow that fan kicks on (right around 220*) and forces air through.

You will never get consistent deltas without the fan clutch working properly. But... Anything less than 10-15* is acceptable.
 

·
Super Moderator
Joined
·
9,676 Posts
I'd say get a tstat for replacement unless that was done with all the other work.
 

·
Administrator
Joined
·
29,510 Posts
despite your normal ECT what we are trying to say is u can't use your delta's as a comparison against a database compiled of trucks that had a properly working fan clutch's

so it's not worth discussing until you get it fixed
either with he BPD conversion , a OEM snowplow or stock clutch
 

·
Registered
Joined
·
167 Posts
Discussion Starter #10
thanks guys. i get a little... obsessive with a dash of denial and hope haha.

plan to do the BPD 7.3 conversion. Looks like they use the Sever Duty Hayden... 108 on amazon. Anyone know of a better fan or deal?
 

·
Registered
Joined
·
167 Posts
Discussion Starter #11
got my 7.3 fan clutch installed.

i don't get it. at all. But everything so far seems fine.
It's hard to do the test in San Diego, lots of hills and everyone drives 75mph.
So I just romped on it, 75-80, moderate engine load, etc.

Averaged 6-9* delta
Max was 13* and that's running 80mph and immediate decel dropping my ECT.

Before oil cooler deltas were 18-20*... so I2sure it was plugging, but probably not as bad as I thought. ECTs did climb though.
 

·
BBBRRRRRTTTTT
Joined
·
6,255 Posts
When using the cleaners its not unexpected fro some crap to get loose and clog the new cooler. If your 10 degrees or under at 70 unloaded I wouldn't sweat it. If you got a warranty I would have them put in a new cooler
 

·
Registered
Joined
·
167 Posts
Discussion Starter #13
When using the cleaners its not unexpected fro some crap to get loose and clog the new cooler. If your 10 degrees or under at 70 unloaded I wouldn't sweat it. If you got a warranty I would have them put in a new cooler
thanks, i think all is well. i can't wrap my head around how the fan fixed anything. Oil is water cooled, water is rad cooled... ECT has stayed about the same, maybe 2* lower. But EOT has improved dramatically.

and thanks for your patience with the Gryphon.
 

·
Registered
Joined
·
167 Posts
Discussion Starter #14
Thanks again guys, I'm pretty sure it's completely fixed. Ran her to 95mph up about 1/2 mile at maybe 4-5% grade, hit 13* delta max and dropped to around 8 once I let off.
 
1 - 14 of 14 Posts
Top