Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Alright, I've got a 2003 F550 with a 7.3. Before I started here, a tech started to work on this old girl. He changed all 8 injectors, both heads, turbo, crank vent, fuel lines to head, the CPS, engine wire harness and spliced into the main harness. Currently its a no start. Oil pressure to nozzles are only 32 psi not enough to fire. the camshaft sensor is new, but nothing reading on the tach when trying to start. Everything LOOKS right. The only thing I can find wrong is the exhaust backpressure sensor is broke and they tried putting just the plug on the 2 pins. Cranks find, just no start. I'm thinking that the HPOP is inop. Any ideas?
 

·
Premium Member
Joined
·
2,689 Posts
Download Forscan to check for codes and engine readings -- PC version is best, but use whichever platform you have available

The 7.3 is not super complicated, but you need to know what the PCM 'sees' in the engine parameters

Fuel pressure would be good, you need a gauge and thread adapter

Check the oil reservoir to see if it is full(about 1 inch down)

check the harness for obvious rubbed spots -- connectors disconnected, stuff like that
 

·
Premium Member
Joined
·
2,689 Posts
The right hand position in this pic is after the filters, so would give the most accurate reading
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks for your reply, and sorry I didn't get back to you sooner. Been cleaning this shop up. The fuel pressure is around 62psi. I decided to go around and drain all the oil, including the HPOP and replace it. Got some nice metal chunks out of the bottom. Waiting to filter the oil to see how bad it is. Not good
 

·
Registered
Joined
·
279 Posts
I don't have much to add but the lack of tach readings while cranking is normal. You'll only see the tach move during cranking on the older clusters with the mechanical odometer. Your 03 has a digital signal that isnt sent to the gauge until the engine is running
 

·
Premium Member
Joined
·
2,689 Posts
"Got some nice metal chunks out of the bottom"

Bottom of the HPOP reservoir?? That is filtered oil - only way chunkies could get in there would be if they were put in there or got past the oil filter

Out of the oil pan drain?? That still needs to be looked at - lifter rollers, piston skirt fragments, gear teeth, etc.

Pictures would be good
 
1 - 8 of 8 Posts
Top