Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1
My fog lights don't work. Haven't since I bought the truck. At first I figured it was because the housing/bulbs were broken. So after I hit a ditch/mailbox about two weeks ago, they were replaced on Wed. Still no dice. The headlight knob was also broken; it would come off when I tried to pull it out. Bought a new knob, and found out that it in fact doesn't come out when pulled on (didn't try super hard, I don't want to have to buy another new knob). There is also an aftermarket switch mounted under the dash, with a picture of a headlight on it. I assume this truck must have aftermarket fog lights. Flip the switch...nothing. (I was hoping this would be a winner since it didn't do anything before and the lamps/bulbs were new).

So I figure its the fuse. The owners manual says its a 10 amp fuse (red one) in slot #43. I open the CJB and there's a 15 amp fuse in there (blue).

Is having the wrong fuse in there a problem/something that could cause damage? I went to autozone and got some replacement 10 amp fuses, but I'll have to put them in tonight after work.

Hopefully someone has some input?
 

·
Registered
Joined
·
19 Posts
Do you have voltage at the aftermarket switch? If they weren't working maybe the previous owner removed the power source. Also if they are aftermarket chances are its not on the factory fuse. Are the lights stock? Does the harness to the fog lights look stock? Follow the harness back to see where it goes.

Also the headlight switch should pull out easily when the headlights are in the on position. You might have a switch for a truck without fog lights.
 
1 - 2 of 2 Posts
Top