Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
Well...as murphy's law kick in on my Sunday of planned sitting around eating and sucking down some cold ones while watching football...

my 2006 F250 decides to start something new.

The Tow/Haul light came on and started flashing with the CEL light on continuously with an associated shutter in the transmission. I am able to read the codes with my CTS;

P0700- Transmission Control System Malfunction.
P0758- SSB control Circuit Electrical Failure.
P0976- SSB control Circuit Low.

What would the best place to start troubleshooting? or what sensors/controls would be best to replace?

Any advice is greatly appriciated,
Damon

PS- I do not have a good working knowledge of this transmission.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #2 ·
I just found on another forum that the P0758 and P0976 codes point to the;
2-3 shift solenoid.

Is this an easy replacement? Is it located internally or Externally?
 

·
Administrator
Joined
·
31,378 Posts
the pan gasket is reusable and it's a good time to just dump the fluid and add 7ish more quarts

you may have a wire issue however at least by my untrained diagnostics
 

Attachments

·
Registered
Joined
·
44 Posts
Discussion Starter · #5 ·
the pan gasket is reusable and it's a good time to just dump the fluid and add 7ish more quarts

you may have a wire issue however at least by my untrained diagnostics
Thanks ZMANN,

I notice in your Pic you submitted, there are several Solenoids. Which one is the 2-3 shift Solenoid? Or should I replace all of them while I'm in there? Are they all different? or the same part number....?

Thanks
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #6 ·
Well...as murphy's law kick in on my Sunday of planned sitting around eating and sucking down some cold ones while watching football...

my 2006 F250 decides to start something new.

The Tow/Haul light came on and started flashing with the CEL light on continuously with an associated shutter in the transmission. I am able to read the codes with my CTS;

P0700- Transmission Control System Malfunction.
P0758- SSB control Circuit Electrical Failure.
P0976- SSB control Circuit Low.

What would the best place to start troubleshooting? or what sensors/controls would be best to replace?

Any advice is greatly appriciated,
Damon

PS- I do not have a good working knowledge of this transmission.

Well, I really need some more knowledge about this. I there anyone out there with a good working knowledge of this issue. Otherwise, I will leave it up to ford.

Thanks,
Damon
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #7 ·
FOUND THE PROBLEM. Main transmission wire harness wasn't routed correctly (from previous work) and rubbing on the drive shaft...repaired and rerouted wires...cleared codes and BAM! no more problem.
 
1 - 7 of 7 Posts
Top