Ford Powerstroke Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1991 F-350 7.3 Automatic Non turbo truck. The other day I noticed the RPMs seemed kinda high for the highway and the shifting was harder than normal. I looked at the OD cancell switch and it was blinking. I pulled over and turned off the engine and restarted and it went off for a while and then came back blinking with the same shifting issues. I am new to this forum and I could use some advise on where to start troubleshooting this.

Thanks in Advance
 

·
Registered
Joined
·
623 Posts
when i had my old idi the tranny did the same thing o/d light was blinking hard shifts and took it to the tranny shop and the tranny was shot.
 

·
Registered
Joined
·
699 Posts
+3 my did it once but i was getting it built anyway. It threw a few codes. (some of the shift point sensor codes and a few other) Long story short it is gonna cost some some dolla bills
 

·
Registered
Joined
·
1,874 Posts
that means the tranny is more than likely shot
Before you do this I would check the sensor in the rear end. Mine did something similar and it was the abs speed sensor.
 

·
Registered
Joined
·
5,229 Posts
All 3...yes 3 times I had to have my tranny replaced it did that exact same thing for a few days before it completely went out.
 

·
Registered
Joined
·
1 Posts
Will also flash if fluid is hot. Mine was flashing when I got it and was just rebuilt 7,000 miles ago then went out one night and when pulled out found the input shaft to converter spline was striped. now metal was pumped all through the tranny. Had it rebuilt and every onceawile when towing a long distance the light will come on and shift hard till it sits over night then go back to normal. also when rebuilt put on a large tranny cooler. (truck is a repo truck with a wheel lift so it tows alot)
 

·
Registered
Joined
·
28 Posts
Mine flashes constantly, but it's just the sensor. Shifts fine, fluid is cool and hits overdrive fine, so i'm not in much of a hurry to fix it!
 

·
Beach Bum
Joined
·
26,652 Posts
Will also flash if fluid is hot. Mine was flashing when I got it and was just rebuilt 7,000 miles ago then went out one night and when pulled out found the input shaft to converter spline was striped. now metal was pumped all through the tranny. Had it rebuilt and every onceawile when towing a long distance the light will come on and shift hard till it sits over night then go back to normal. also when rebuilt put on a large tranny cooler. (truck is a repo truck with a wheel lift so it tows alot)
still, it should not do that. first upgrade the cooler to a 7.3 or better yet a 6.0 cooler. if it still flashes after that. something is STILL wrong with the trans.


Mine flashes constantly, but it's just the sensor. Shifts fine, fluid is cool and hits overdrive fine, so i'm not in much of a hurry to fix it!
then its just a early warning that its about to go out or is just needing rebuilt from wear.

my 97 did that but i sold it so i didnt get it rebuilt. :woot:
 

·
Registered
Joined
·
47 Posts
I had this problem for a year or more, had trans rebuilt $2000.00, replaced all the speed sensors, took to dealership & they finnally decided to try the instrument cluster. Fixed it. Speedo was sending false readings.
 

·
Registered
Joined
·
28 Posts
I agree w/bearcat. Just because an idiot light is blinking, doesn't mean the end of the world... I had a customer of mine TOW his car in because the check engine light came on. He thought the motor was shot. Turned out to be his gas cap was loose (P0442).

The tranny in my truck was rebuilt about 10k miles ago (have all the receipts/records) along w/a new cooler. Like I said before, it's just a sensor, or even a bad wire/ground for the light.

When your diagnosing a problem, don't automatically jump to the worst (or most expensive) conclusion. Hell, maybe try a fluid/filter change if it hasn't been done in a long while. Old, thin fluid can cause hard shifting and quick overtemps.
 

·
Registered
Joined
·
48 Posts
my old 7.3 did the same thing one night coming home from work pulled over and cut it off then back on and hasent done it since
 

·
Registered
Joined
·
1 Posts
Tranny problems

I had some similar problems, except that lost OD and then 3rd gear. I put a new shift solenoid on, which helped for about 400 miles, then I lost OD again. I had it rebuilt, new converter too. It holds the 3rd way too long before shifting and every so often the OD lite starts blinking when it shifts 2-3. The shop told me to drive it for a while and see if the shifting will adjust, but I think I'm in the process of getting screwed. Does anyone know if this might be a simple adjustment or if it's more of an internal problem.
 

·
Registered
Joined
·
1 Posts
I have a 1991 F-350 7.3 Automatic Non turbo truck. The other day I noticed the RPMs seemed kinda high for the highway and the shifting was harder than normal. I looked at the OD cancell switch and it was blinking. I pulled over and turned off the engine and restarted and it went off for a while and then came back blinking with the same shifting issues. I am new to this forum and I could use some advise on where to start troubleshooting this.

Thanks in Advance
Check your pmc in the trans.it controls the solenoids to the torconverter. And is not locking it up,Mine burnt up about a month later and cost $2500 to fix.
 

·
Registered
Joined
·
320 Posts
My brothers 92 idi will start falshing everyonce in awhile and he just disconnects the batteries for 15-30 minutes and it resets the computer for the transmission and then its fine for a while or untill your slowing down for a light and by the time you get there its green and you get back into it and then it will come on, i guess it thinks your trying to lug the tranny by slowing down in i guess third gear and then getting on it to speed back up "scares" it so it goes into limp mode. Maybe he needs to try changing the abs speed sensor??
 
1 - 15 of 15 Posts
Top