Ford Powerstroke Diesel Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter · #1 ·
Ok so I am thoroughly frustrated and pissed off with my work truck. I took it to a shop that will remain unnamed because they had a couple "certified ford diesel techs" and the truck was acting up. Before I get too far my rig is a 2003 F-250 cc lariat fx4 4wd with the 6.0l. Only mods are BPD FICM(58 volt 6phase), Blue spring upgrade, Cold Air intake and 18in rims with 285/65/18 toyo open country a/t. The truck was giving me trouble on hot restarts. So they found these codes:po006a
po0275
po401 & po404
po671
po2284 &po2291
Now I let them change the oil and they refused to put the 15w40 royal purple back in the tuck, the replaced egr valve and cleaned ports(I think that was bs)
So after 1k in they tell me they cant figure out if its the icp or hpop so I better replace them both. Got my truck out of there and tore truck down to due the icp. took intake off, turbo and all. replaced ICP myself and checked pigtail for oil and it was fine. ICP got replaced due to oil leak at the oring. IPR was re-screened and all orings and gaskets replaced. It ran rough still gave a extended hot restart so I figurred I would need the hpop. Had to drive it to work today and on the way home the idiot gauge for the oil dropped to nothing at idle. If I revved the engine it would jump back up so I drove home with out letting it drop again. I hooked up scanner and ICP desired and actual where dead on target. IPR duty cycle at 3000rpm was 33%. recorded about 20 minutes of run time shut truck down tried to restart and it just cranked. went to try again and the starter jus made a click. So now I either have a bad starter hydro locked engine or locked up engine and am just overwhelmed. Please point me in the right direction.
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #3 ·
12.59volts passenger side and 12.48volts driver side
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #4 ·
just to add I have always had a KMA error.(keep memory alive) And both batteries are brand new.
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #6 ·
Update: Still dont know if engine is hydrolocked or locked up period but found out the starter is trashed. Will replace that tommorrow and let yall know. Thank you for the help.
 

·
Banned
Joined
·
1,120 Posts
like i said once you get the new starter on and get it to spin freely.1 st listen to see if you hear the bongo drum sound.if you hear that get ready for complete tear down.but if not and it spins freely turn key on and off cycling the fuel pump about 5 times.then try to spin it if it doesnt spin and acts like its hydro locked.then you know you have a bad oring on an injector.

the next step pull driver's side it's the easiest and start pulling glow plugs till you fined the one that lets the motor start spinning freely again
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #8 ·
still working on it.... been raining so cant really do anything will update when I can.
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #10 · (Edited)
Alright guys got a new starter in it and motorcraft oil filter cap and filter. still having problems on hot restarts. if i turn the truck off and then try to restart imidately it will crank for about 10 sec and start. However if I wait three minutes(i timed it) it will take almost 30-60 secs to crank. Now IPR is at 85% on these long starts and the ipc reads 350 psi till it finally hits. So I am leaning towards a weak HPOP. just wondering what yall think before I bite that 700 dollar bullet. another thing is that my oil change sticker says 5w20 syn. Does rotellia make 5w20 or did the shop put the wrong oil in after refusing to go back royal purple?
 

·
Sinister Diesel Sucks!!!
Joined
·
2,498 Posts
I hope they just used the wrong sticker on ya. I dont know any diesel oils rated at 5W-20. Shells full synthetic, T6, is 5W-40. You might wanna give them a buzz or check your receipt and see what they charged you for
 

·
Registered
Joined
·
4,564 Posts
Have you done a pressure check yet? If you have shop or compressed air, that would be a good next cheap check.

How about oil pressure on the low side? The oil pressure sensor only feeds into the dashboard and not the PCM. This activates at 5-7 psi. It's also a on off digital type meter with no in-between. I don't know an actual good reading, but the bypass valve at the low pressure pump activates at 75psi. The other two pressures I see are in the oil filter gets bypassed at 20 PSI and the oil cooler at 25 psi. So if it's pumping at 6 psi, the gauge will show good pressure, but if that's all it gets to, may not be pressure to power the high side of the oil system. The only reason I bring this up is you mentioned the gauge went to 0 at one point which means oil pressure on the low side was less then five pounds. Something was restricting low pressure oil flow.
 

·
Real Men of Genius
Joined
·
5,309 Posts
Issues with hot restarts is a common STC fitting issue with 05-07 trucks.... even though yours is an 03, I would check it to make sure that the shop didn't "upgrade" you with a newer STC fitting design.
 

·
Sinister Diesel Sucks!!!
Joined
·
2,498 Posts

·
Real Men of Genius
Joined
·
5,309 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter · #16 ·
When I get home I am gonna pull lpop regulator. The engine oil is the t6 5w40 I don't know lpop pressure. I do have a shop compressor. How can I do an air test without pulling icp or ipr? I am still having to drive truck unfortunately.
 

·
Sinister Diesel Sucks!!!
Joined
·
2,498 Posts
You dont know lpop? Unfortunatley air testing through the ICP or IPR is the best way. There are points on the HPO rails but then you are only checking the rails one side at a time due to check valves. ICP is the easiest way to do it. You can get at it from underneath in the back.
 

·
Sinister Diesel Sucks!!!
Joined
·
2,498 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter · #19 ·
Sorry suppose to say lpop psi. Still at work thanks everybody this truck has me in a bind.
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #20 ·
alright guys I havent had time to get on here but I have had a few issues come up. First off when the no hot start started to happen there was a pop noise under the hood(co-worker remind me of this) and now after replacing the icp the truck will stall if you give it a little throttle and then hit the brakes. Another issues is the ac quite work about this time too, as did my auto lock hubs. think those two issues are the vaccum pump since it no longer makes any noise and all test indicate it is dead. going out after dinner to pull the valve cover on the passenger side do to a hunch based on stuff i read about oil rail oring failure after injector replacement. I replaced number 3 a while back, probably 3 months ago.
 
1 - 20 of 24 Posts
Top