Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
741 Posts
Discussion Starter #1
This is my third pump that failed. I have tried different things to get my Fass to last but perhaps it is time to move on.:dunno: To top it off DPP has no motors in stock & don't know when they will get some so they can't send me a new one. They have oked me to have someone locally look at it. Crossing my fingers there.

Anyone running Leons pump? If so how's it holding up? How many miles do you have on it?

I have asked on BFT if they have a DIY Scorpion but pretty sure they don't.

Is ther any other viable options?
 

·
Registered
Joined
·
4,206 Posts
i got 1100 miles on one of Leons pumps befor emy truck was totaled. tested a couple for him, the final revision (the one i put 1100 on) ran great! i know its not many miles but it held steady pressure, it has mounting holes, and its beefy. ill be putting it back on my replacement truck over the next couple weeks.

IMHO, go with Leons, FASS isnt working for you, and BFT isnt an option for your DIY. that leaves you with the smaller pumps or Leons. im not holding FASS and BFT on a higher or lower pedistal than Leons, or vice versa. (dont want to start a debate) Leons latest pump has been great for me.

i had a prior version for my D2 side, it worked great on D2, never tried it with WVO.
 

·
Registered
Joined
·
741 Posts
Discussion Starter #3
i got 1100 miles on one of Leons pumps befor emy truck was totaled. tested a couple for him, the final revision (the one i put 1100 on) ran great! i know its not many miles but it held steady pressure, it has mounting holes, and its beefy. ill be putting it back on my replacement truck over the next couple weeks.

IMHO, go with Leons, FASS isnt working for you, and BFT isnt an option for your DIY. that leaves you with the smaller pumps or Leons. im not holding FASS and BFT on a higher or lower pedistal than Leons, or vice versa. (dont want to start a debate) Leons latest pump has been great for me.

i had a prior version for my D2 side, it worked great on D2, never tried it with WVO.
Bruce M suggested I ask if BFT's motor will fit on a Fass pump head. He seesm to think it will. I have asked that question BFT. That is if it is the motor & I think it is. So that may be an option.

I find it hard to shell out 400 bucks for leons pump when I can just send mine in for a free warranty replacement( assuming DPP hard another pump to send me which they don't) but it is getting to the point that I am going to have to do something. I haven't heard many reports on Leons pump & am a little leary to go from one problem to a yet unproven ( in my mind) pump & perhaps end up with similar problems. But everything I have seen from Leons seems to be good quaility. I just bought his inline heater for my centrifuge & it works great. Really happy with it.

I am going to get my Fass checked out locally to see what wrong with it first before making a final decision.
 

·
Registered
Joined
·
971 Posts
When FASS told you to look locally, what exactly did they mean? Like if someone near you has a pump to replace it? Im just curious since it has to do with their warranty.
 

·
Registered
Joined
·
4,206 Posts
id try and get it in writing too...
 

·
Registered
Joined
·
741 Posts
Discussion Starter #6
They told me that I could take it to someone locally & have it taken apart to see what's wrong with it. I probably should get it in writing but DPP has been very good to me & I feel I can trust their word.

False alarm anyway. I found the problem. Did some more checking just to be 100% sure that the Fass was dead & found the ground wire connection for the Fass wiring harness was loose. Tightened it up & Fass is working now.

Thanks for everyones help.
 

·
Registered
Joined
·
4,206 Posts
good to hear its worked out, no waiting for a pump!
 

·
Registered
Joined
·
2,412 Posts
Hmmm what killed your other 2 fass pumps? I am at about 2.5 years and 55k on my fass and so far so good, no issues. I have seen lots of talk about fass pumps failing and cant help but think it will happen to mine some day too....
 

·
Registered
Joined
·
741 Posts
Discussion Starter #9
Hmmm what killed your other 2 fass pumps? I am at about 2.5 years and 55k on my fass and so far so good, no issues. I have seen lots of talk about fass pumps failing and cant help but think it will happen to mine some day too....
I'm pretty sure it was cold VO in the pump on switchover in the winter. My first pump lasted almost 20k miles with no problems & then crapped out in early January when the temps really dropped. At that time I assumed that my pump had just crapped out & a new one would last at least as long as the first. Then the replacement died 2 weeks after installation. This prompted me to starting thinking alot more about what was the cause. The only difference I could think of was the colder temps. All my system is heated but the pump itself. On intial switchover the VO in the pump has not been heated & would be very thick. This was putting extra stress on the motor. Keep doing this every day & the motor cannot handle it. So for my third pump I did a HH wrap around the pump head so it will get heated & warm up the oil in it. That third pump is still going & I have close to 20k miles on that.

I know others live in cold areas & most likely don't heat the pump head & have had no problems with their Fass so I cannot comment on why it has been a problem for me. But it seems to have solved my problem.
 

·
Registered
Joined
·
2,412 Posts
Interesting thought. This is another reason I put about 5-10% d2 in my vo tank when its cold out. I know we dont see the same cold you guys see... We did have 3 days in a row where the high was 30 ish and 15 to 20 at night. Oh I miss that. 30 days in a row now of 100+ and 108 yesterday!
 
1 - 10 of 10 Posts
Top