Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
Well thanks in advance for all the help this forum has giving me.

Here is what I have going on, last weekend I got my truck ready for a weekend road trip to Oklahoma from Dallas changed the oil, fue and air filters on the truck and the next morning out we whent to Oklahoma two hundred miles on the trip going up a hill just pass the red river the truck stared to miss really bad and it finally died, then I would crank it and nothing like it was out of fuel soi took the engine filter cap off and it was bone dry. I would turn the key on and no fuel would go up the line...not good!!!! finally after a while she started to pump again after the pump cool down and ran fine so we decided to go back to Dallas. Once in town i got a new fuel pump for her and it was working fine till later on the day it started to lose power really bad, i then got some DTC's injector low input code on 1,4,6,7 so i decided to replace the injectors and see what would happen then once it was all back together it was running fine codes for the injectors where gone but when going up a hill it started loosing power and running really bad like it was missing and about to die, got DTC for cylinder 5 contribution balance fault F**K got new injector and remplaced number 5, back all together and same problem runs good but up a hill it goes to Sh*T and same code. WTF IS GOING ON GUYS I NEED SOME HELP UP HERE.:doh:

This truck has 230k on it never had any problems untill about 220k when things started to go bad I have changed:

Alternator and Batteries
FICM
EGR
IPR Valve
HPOP Fitting
Fuel pump
Cam & Crank Sensors
 

·
Registered
Joined
·
597 Posts
first thing I would do is get a fuel pressure gauge and check the fuel pressure when under load. Should be around 55 psi. It should never go below 40 psi. If it does, you will burn up the injectors.
 

·
Registered
Joined
·
5 Posts
need some help. i have an 06 250 and when i start from a stop it poors black smoke and acts like it doesent wana go then it finally takes off but slowly. once i get goin its fine till i stop or slow down. just cleaned my egr valve and its still doin it. whats my problem.
 
1 - 4 of 4 Posts
Top