Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Can anyone tell me what this is for? It is behind the pedals near the pcm. I just bought the truck from someone, and they have a ton of accessory wiring, much of it not hooked up. I am trying to tie up some loose ends (literally). They tapped into the wiring for this box, and one of the wires (red) is loose. Can anyone shed any light on this for me?
 

·
Registered
Joined
·
362 Posts
99% sure it is the amplifier box for an Isspro EV1 pyrometer.

Does it look like this?


Red is an ignition source. (Constant power with key on)
The other red with white goes to the negative lead on thermocouple.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
yup thats exactly what it is. I guess it looked factory to me... He had 3 isspro guages in the pillar pod, but none of them work. Ill have to check into the installation instructions for them. thanks a bunch. I was wondering why i couldn't find anything in the manual...
 

·
Registered
Joined
·
362 Posts
yup thats exactly what it is. I guess it looked factory to me... He had 3 isspro guages in the pillar pod, but none of them work. Ill have to check into the installation instructions for them. thanks a bunch. I was wondering why i couldn't find anything in the manual...

That's odd none of them work, I wonder if the thermocouple got unhooked? Could be why there is a loose wire there. Here are some good instructions for a 3 gauge install. They should help give you an understanding how it is all hooked up so you can check over and troubleshoot the install. It doesn't really show anything about the amplifier boxes, but they are pretty straight forward if I remember right. You should see another amplifier box in there somewhere though if he has a trans temp gauge, boost gauge will not have one. (Assuming the other 2 gauges are both the EV1 model as well)
 
1 - 4 of 4 Posts
Top