Ford Powerstroke Diesel Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2000 Ford Excursion with the 7.3 Power stroke that I purchased in 2003 with 42,646 miles on it and have been diligent in keeping up with required maintenance but on November 13th 2019 she just up and died on me and to this day mechanics have not been able to find the problem. I am giving the details leading up to the issue and what has been done since in hopes that someone might have any suggestions on what to look for and any help would be greatly appreciated.
In October 2018 at 215,300 miles the engine oil cooler was replaced do to a leak. In August of 2019 at 222,078 all 8 injectors, all 8 glow plugs, the ICP sensor, both valve cover gaskets and harnesses were replaced all with ford parts. In October 2019 at 223,985 miles had a new paint job done and the company that did the paint job also detailed the truck inside and out including the engine. On November 13th 2019 at 224,942 miles the truck just died on me as if the key were turned off and has not run since.
I had my truck towed to the guys that replaced my injectors not only because they did that job but also because they only work on 7.3 Power strokes. Since they have had it the Powertrain Control Module (PCM), Injector Drive Module (IDM), Injector Pressure Regulator (IPR), Cam Position sensor and the main engine electrical harness have all been replaced and still she does not run. All parts were new except for the PCM which was rebuilt and tested. In the first week of September my mechanics said they were at a loss and I needed to take it somewhere else and they did not charge me for any of the work they had done to date. Great guys.
So the truck was towed to a local Ford dealership that came highly recommended by my guys and they can’t figure it out either so far. They did tell me that they disconnected the Exhaust Back Pressure Sensor and were able to get the truck to run but that it ran very rough and when the sensor was reconnected the truck went right back to square one.
Has anyone ever heard of or come across such a thing or does anyone out there have any suggestions PLEASE. I would really appreciate some help. Thanks

Tony
 

·
Registered
Joined
·
1,105 Posts
Woah dude. If ford can't figure it out then you're in trouble. It's a shame too just having it painted. I'd say detailing under the hood caused some electrical issue. They may have pressure washed?

It's gotta be electrical and ford should be able to trace and see everything.

Hopefully someone can help you. Did you talk to the mechanic directly? Is it someone over or under 40?

Sent from my SM-N960U using Tapatalk
 

·
Premium Member
Joined
·
11,046 Posts
Since it’s an excursion did anyone diagnose the PATS system? It’s only a control module and receiver but when they go bad no starty start.

The excursions are unique with the 99-03 7.3ls since the superduties did not come with PATS.

also never truck a mechanic. Not that they are liars but they SHOULD HAVE had good reason to replace the expensive parts and it still doesn’t start leading to poor diagnostics on their part. Not that it was intentional etc.

do you have access to a newer scanner or a laptop that you can download forscan program and buy a usb to obdII adapter. Forscan is free and incredibly helpful when diagnosing a no start situation
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Woah dude. If ford can't figure it out then you're in trouble. It's a shame too just having it painted. I'd say detailing under the hood caused some electrical issue. They may have pressure washed?

It's gotta be electrical and ford should be able to trace and see everything.

Hopefully someone can help you. Did you talk to the mechanic directly? Is it someone over or under 40?

Sent from my SM-N960U using Tapatalk
No I haven’t talked to the mechanic at Ford yet. I wanted to give them a little more time and see what if any ideas I can get from this forum first.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Since it’s an excursion did anyone diagnose the PATS system? It’s only a control module and receiver but when they go bad no starty start.

The excursions are unique with the 99-03 7.3ls since the superduties did not come with PATS.

also never truck a mechanic. Not that they are liars but they SHOULD HAVE had good reason to replace the expensive parts and it still doesn’t start leading to poor diagnostics on their part. Not that it was intentional etc.

do you have access to a newer scanner or a laptop that you can download forscan program and buy a usb to obdII adapter. Forscan is free and incredibly helpful when diagnosing a no start situation
Thanks Justin I have not heard anything about the PATS system I’ll have to investigate it as I don’t know what that is and ask them about it. So far I have been very lucky with my mechanics. All those parts they replaced I was not charged one cent for parts. I know Ford will not do the same but my main mechanics have already replaced the big stuff. Thanks again
 

·
Registered
Joined
·
1,105 Posts
Thanks Justin I have not heard anything about the PATS system I’ll have to investigate it as I don’t know what that is and ask them about it. So far I have been very lucky with my mechanics. All those parts they replaced I was not charged one cent for parts. I know Ford will not do the same but my main mechanics have already replaced the big stuff. Thanks again
Honestly, I'd probably offer to pay the parts since you have a good relationship... That is if you can swing it financially.

Get forscan setup. For the Bluetooth adapter don't get the cheapest. I have the obd MX. It was about $20. I have the cheaper $10 one and it works but oftentimes those won't work on the powerstroke. The first cheapo I had didn't work. I bought the second cheapo for my Hyundai and luckily it worked.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Honestly, I'd probably offer to pay the parts since you have a good relationship... That is if you can swing it financially.

Get forscan setup. For the Bluetooth adapter don't get the cheapest. I have the obd MX. It was about $20. I have the cheaper $10 one and it works but oftentimes those won't work on the powerstroke. The first cheapo I had didn't work. I bought the second cheapo for my Hyundai and luckily it worked.

Sent from my SM-N960U using Tapatalk
I offered to at least pay for the parts many times and they refused. Once the truck is running I will offer again or try to come to some kind of agreement. They are the best and I do want to use them in the future
 
1 - 7 of 7 Posts
Top