Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys, i have a 94 7.3l IDI with 332,000 miles, and when I start it up it is really hard to start, an runs super rough. Also, it smokes like a freight train, all white diesel smoke, doesn't burn oil at all. Injectors and return lines were replaced about 25k miles ago. And it smokes when it's hot, cold, at idle, and just driving around. Runs smooth once it's warm, except every so often it has a little drop like a cylinder not firing and gets a bigger puff of white smoke. Any suggestions on how to reduce the smoke? Fuel pump has never been tinkered with either. It's had a couple ether starts also. The glow plug relay is working also. I just want the truck to run for another 300k and not smoke me out constantly. It has a new air filter and fuel filter isn't that old. Anything would help! I just don't know what else to try? Thanks!
 

·
Registered
Joined
·
2,489 Posts
Does the smoke linger in the air, and smell sweet? Hows your coolant level?

Hard starts with fairly new return lines and injectors could mean bad timing. If it gets better once warm, that means cold idle kicked off and isnt running as advanced in timing, though usually retarted timing results in white smoke (if I remember correctly).

Any way to get a video?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Coolant is good, its that white smoke that burns your eyes, real heavy then it lightens up to a constant little cloud rolling out. I will work on Gettin a video for more explanation of it.
 
1 - 4 of 4 Posts
Top