Ford Powerstroke Diesel Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
got a quick question? Whenever i am pulling a trailer of any sort and my ECT gets to about 210 deg i start to smell a hint of engine coolant come through the truck and when it gets back down to 190 and 180 the smell is gone. What are some of the possibilities that could be going on here. Any help would be great thanks!!
 

·
Registered
Joined
·
224 Posts
Mine is the same I have not had any issues I would add a coolant filter if you have not done so. And change to a cat elc other then the ford junk
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
@altadiesel i just had a chance to check for the white varnish you had mentioned and it looks like it has overflowed onto the top of the degas bottle and onto other stuff right underneath it and on the bottom of the hood. What should i look into now?
 

·
Registered
Joined
·
1,228 Posts
Do you have an EGR cooler still there? Is it studded or factory head bolts? If it is studded do you have Ford HG's or Black Onyx HG's?

I would do a psi test on coolant system. You either have a bad EGR cooler or blown HG's.

Sent from my DROID RAZR using AutoGuide App
 

·
Registered
Joined
·
137 Posts
One of two things, bad gaskets or EGR is blown.. Most likely needs a new oil cooler as well. That's the root cause to a bad EGR cooler. Most likely the EGR.. Gonna run you around $700 to fix..


Sent from my Autoguide iPhone app
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top