Ford Powerstroke Diesel Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
First time poster, I apologize up front if these questions are elementary...I just bought a used 2015 F-250 Platinum with 130k miles on it.

Unfortunately, it's got a check engine light with Code P24a0. I'm assuming it's because I don't drive it enough to complete a full regen...but I'm not really sure. My local dealer wants $350 to do a manual regen and clear the code. The independent shops around me want $250+.

I figure it's stupid to pay that money since I'm in the process of ordering an EZ Lynk with GDP Tunes, 4" "weight reduction" pipe and a No Limits EGR kit w/flow through. I'm assuming this should fix my cel and I'll be good to go. Thoughts?

Here's my real question: Since there are so many miles on my truck, I want to plan on a worst case scenario with the bolts on the exhaust manifold. I keep hearing horror stories of them snapping off while trying to remove them. What should I have on hand if these damn things snap off?

I plan on buying a left handed drill set and a helicoil set with 1/4 tap and 20 count threads. Do I need anything else? What length stainless steel bolts should I get to replace the crappy ones that are coming off? Also, if they do break and I do have to re-tap with the helicoil mentioned above, is it as easy as buying 1/4 hex cap screws with a 20 count thread?

Last stupid question (for now)...Can I just pour in the coolant that came out back in (it was flushed 6 months ago)? Or, do I need to buy all new coolant and some sort of vacuum device to refill the coolant system? I don't see anything on putting coolant back in, just stuff on how to remove it.
 

·
Premium Member
Joined
·
12,021 Posts
When I did mine I reused the coolant. Just make sure your container is clean, oil free, nothing else inside etc etc etc.



For the EGR bolts you can try the soaking several times before and after it's up to temp. I've heard of plenty people getting them out easily when soaking after the motor is at normal temps.



Asking for a friend....what did you pay for the truck??
 

·
Registered
Joined
·
1,598 Posts
If you're worried about the bolts breaking, leave it all in place and not worry about it. Removal of all that junk is not a priority/needed.
 

·
Premium Member
Joined
·
2,195 Posts
That code isnt necessarily because it needs to regen per se. It is because it can't perform one. Fuel injection, ignitor, failing EGT sensor.... some other things I'm sure.... have failed and it can not get the exhaust temps high enough to burn off the soot. Your plan may or may not solve the issue.
Like HA said, soak the bolts in Areokroil (sp?) PB. I'm not a fan of WD40 unless it is for cleaning tar off paint. A hot motor will help too.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
When I did mine I reused the coolant. Just make sure your container is clean, oil free, nothing else inside etc etc etc.

For the EGR bolts you can try the soaking several times before and after it's up to temp. I've heard of plenty people getting them out easily when soaking after the motor is at normal temps.
That's my plan. I'm going to use liquid wrench for a week beforehand (while hot and cold).



Asking for a friend....what did you pay for the truck??
I paid $26,500 for it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
If you're worried about the bolts breaking, leave it all in place and not worry about it. Removal of all that junk is not a priority/needed.
Can you disable the EGR system? Or does the Tuner do that automatically when you select Deleted?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
That code isnt necessarily because it needs to regen per se. It is because it can't perform one. Fuel injection, ignitor, failing EGT sensor.... some other things I'm sure.... have failed and it can not get the exhaust temps high enough to burn off the soot. Your plan may or may not solve the issue.
Like HA said, soak the bolts in Areokroil (sp?) PB. I'm not a fan of WD40 unless it is for cleaning tar off paint. A hot motor will help too.
My cel came on after the truck started a regen while I was in traffic. I was only going about 5 miles and could wait for a full regen. What's also weird is that after that, my truck wouldn't remote start. Also, (this may or may not be important) I had a warning that my DEF was down to 200 miles. I put in 2 gallons of DEF and the truck started remote starting again (weird). However, the check engine light remained on. I drove around for 3 days with the CEL and it drove fine, no loss of power.

Last night I went to O'Reilly's and they cleared the code for me, then I hooked up my travel trailer and drove on the freeway for about an hour at 70 - 75 mph. I never got a pop up on my screen that a filter cleaning was happening...but, I was at fairly high rpm's for a while, so I hope that was enough to burn off some of the soot in there.

Either way, check engine light has not come back on. Hopefully it stays that way!
 

·
Registered
Joined
·
115 Posts
My cel came on after the truck started a regen while I was in traffic. I was only going about 5 miles and could wait for a full regen. What's also weird is that after that, my truck wouldn't remote start. Also, (this may or may not be important) I had a warning that my DEF was down to 200 miles. I put in 2 gallons of DEF and the truck started remote starting again (weird). However, the check engine light remained on. I drove around for 3 days with the CEL and it drove fine, no loss of power.

Last night I went to O'Reilly's and they cleared the code for me, then I hooked up my travel trailer and drove on the freeway for about an hour at 70 - 75 mph. I never got a pop up on my screen that a filter cleaning was happening...but, I was at fairly high rpm's for a while, so I hope that was enough to burn off some of the soot in there.

Either way, check engine light has not come back on. Hopefully it stays that way!
I have a 2011 fully deleted running Tyrant tunes, Tunes which I've never had any issues with.
 

·
Registered
Joined
·
2,252 Posts
The tune will shut off the EGR automatically when you load it.
 
  • Like
Reactions: HeavyAssault

·
Premium Member
Joined
·
2,195 Posts
That code isnt necessarily because it needs to regen per se. It is because it can't perform one. Fuel injection, ignitor, failing EGT sensor.... some other things I'm sure.... have failed and it can not get the exhaust temps high enough to burn off the soot. Your plan may or may not solve the issue.
Like HA said, soak the bolts in Areokroil (sp?) PB. I'm not a fan of WD40 unless it is for cleaning tar off paint. A hot motor will help too.
My cel came on after the truck started a regen while I was in traffic. I was only going about 5 miles and could wait for a full regen. What's also weird is that after that, my truck wouldn't remote start. Also, (this may or may not be important) I had a warning that my DEF was down to 200 miles. I put in 2 gallons of DEF and the truck started remote starting again (weird). However, the check engine light remained on. I drove around for 3 days with the CEL and it drove fine, no loss of power.

Last night I went to O'Reilly's and they cleared the code for me, then I hooked up my travel trailer and drove on the freeway for about an hour at 70 - 75 mph. I never got a pop up on my screen that a filter cleaning was happening...but, I was at fairly high rpm's for a while, so I hope that was enough to burn off some of the soot in there.

Either way, check engine light has not come back on. Hopefully it stays that way!
It might, but I believe that code is the result of low EGT during regen. Towing ingreases temps but unloaded it may not be able to reach the desired temp.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
It might, but I believe that code is the result of low EGT during regen. Towing ingreases temps but unloaded it may not be able to reach the desired temp.
That makes sense. What I found odd was that the regen notice popped up within 3 minutes of me starting my drive. There is no way the engine was up to temperature.
 
1 - 12 of 12 Posts
Top