Ford Powerstroke Diesel Forum banner

1 - 15 of 15 Posts

·
Motor Head.
Joined
·
1,777 Posts
Discussion Starter #1
Ok here is my situation my edge insight cts was working fine,it was added before I did the sct custom tune.After the custom tune it still worked fine.Now the other day i took the insight off to do the latest update and to set it up fuel pressue,when I put it back on the truck,most of my important pids are gone like eot,boost,trans temp,ficm voltage etc... I called edge he said it's because sct tune is on my truck.Has anybody else had this happen,my truck is 04 ,this was and issue last year but I thought they got it fixed.Anybody have an idea.... thanks
 

·
Registered
Joined
·
123 Posts
I would also like to know since I also have the insight and looking to get an sct tuner. Maybe have you tried to contact your sct programer see if they have any answers?
 

·
Motor Head.
Joined
·
1,777 Posts
Discussion Starter #3
Ok I called edge and they gave me and oder update.I put the stock program back on my truck,then installed the cts and had to manually put my vin number in ,after the unit reset ,I had my pids back.From here I installed my custom tune ,then plugged the insight back with the pids working fine.At this point foward,I guess I cant do any new updates.The guys from edge say it's sct taking out the VIN when you add the tunes.

Seems to me I thought if memory serves me that 03-04 trucks dont have the VIN number programmed to the pcm,thats why we have to manually put it in when you first put the insight on the truck.
 

·
Registered
Joined
·
123 Posts
I notice that I have to enter it in every time I update it or have it unplugged.

Sent from my ADR6300 using AutoGuide App
 

·
BANNED
Joined
·
3,231 Posts
I'm not sure about the VIN being programed or not but my SCT shows my VIN (2004) when I go to my trucks information. When I unplug my CTS and plug it back in I have to select ford. After that, it shows my my VIN and asks if this is the correct vehicle. Click yes and I'm on my way, everything shows up just like it did before.
 

·
Registered
Joined
·
21 Posts
That is what happen to me with an 04. I just assumed the VIN was held in the memory of the unit, and I it was a different truck you would have to change the VIN. I had to enter it manually the first time.
 

·
BANNED
Joined
·
3,231 Posts
O ok, I misunderstood you. I had to enter mine in manualy as well the first time. Not sure why my SCT can read my VIN and the CTS can't initially. :dunno:
 

·
Motor Head.
Joined
·
1,777 Posts
Discussion Starter #8
have you'll did the latest updates ? I may have left it unplugged from the truck to long after doing the last update.
 

·
Registered
Joined
·
1,763 Posts
does your mpg work on your cts? mine stays at 99.9 mpg
 

·
Registered
Joined
·
1,763 Posts
yea man haha me to. but yea none of the mileage things works on mine, dont know whats wrong with it.
 

·
Motor Head.
Joined
·
1,777 Posts
Discussion Starter #13
In my case ,i updated my insight it was not plugged in for a couple days when I plugged it back in my pids were gone.I called edge they rolled me back to and older version,then my pids came back,however it could have been that I left it unplugged to long too.

Now I am nervous about changing my tunes .I can read miliage.I think its mostly the 03-04 having the issue .
 

·
Registered
Joined
·
54 Posts
I suggest buying an obdII splitter. i ordered mine from amazon for ike 19 shipped. Dont have to unplug the cts to change tunes and i havent had an issue with the combo:)
I do however have the issue of the pcm on the 03 not written with a vin causing my sct to use an unlock everytime i take it back to stock :( im down to 1 unlock
 

·
Motor Head.
Joined
·
1,777 Posts
Discussion Starter #15
Good idea.
 
1 - 15 of 15 Posts
Top