Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
As the title states my truck use to run 190 ect and about 190-195 eot before i had my studs put in. Then the shops first attempt at doing they used black onyx gaskets without me knowing and they blew withing 5k but my ect and eot were stil the same as before while cruizing and even city driving wasnt realy any higher. So now i made them redo the studs with stock ford gaskets and my ect while cruizing is 200-205 and eot its 205-210 and thats not getting into it at all. So im just wondering what would cause this much of a change? My truck was at their shop for 3 months waiting so since i waited so long i kinda ticked the owner off so im afraid they might have done something but my coolant and oil are all ok and i had a new oil cooler about 9k ago. And they 2 temps never get past 15 degrees apart.
 

·
Registered
Joined
·
460 Posts
Your ECT is way up there! Maybe just need a new thermostat! Your deltas look OK as the temps arent taht far apart! would start with a Motorcraft Thermostat and see what it looks like after that! Also take a water hose and wash your radiator out real good! could also be the fan clutch but would try the other two first and go from there!
 

·
Registered
Joined
·
166 Posts
Discussion Starter #4
My thermostat was replaced a couple thousand miles ago but thats cheap enough i will give it a try. And the fan clutch is plugged in but i havent heard it kick on and i have only put about 1200 miles on since the studs were put on this time. Is there a way i can force it to come on to make sure its working?
 

·
Premium Member
Joined
·
4,670 Posts
Check all fuses, check coolant level, and check fan clutch operation. The last might require an AE or similar scan tool.

You said your truck was there for 3 months? How much of a difference in ambient temps is there in your area between then and now? I wouldn't panic too much if its hot in your area and you're seeing 205* ECT's.
 

·
Registered
Joined
·
109 Posts
I agree with Snake. I live in the houston area and, on a 95+degree day I am seeing ect in the 200-205 range empty. Sometimes up to 210 in stop and go. A few weeks ago I saw 214 pulling a 10k trailer in the hill country going uphill. Around 208-210 on flat ground pulling the trailer. When it is a little cooler I usually see 192 nominal ect. Oil temp always within 5 to 10 degrees. I dont think you have a problem if it is hot where you are.
David
 

·
Registered
Joined
·
166 Posts
Discussion Starter #8
Its hot during the day. Im in the kc mo area. I even had the high temps on a 70 degree night thats what worries me and i have had my truck for 2 years and it never had that high ect temps goin down the highway. If i get into it at all they will climb to over 215
 
1 - 8 of 8 Posts
Top