Ford Powerstroke Diesel Forum banner
1 - 1 of 1 Posts

1 Posts
Discussion Starter · #1 ·
2016 6.7. 55k Miles. Delete / EZ Lynk Tuner / Motorops PSP5 V1.69.2

Doing routine maintenance today I pulled the truck in the garage. Changed oil / filter... started... verified... no issues. Shut down.

Changed rear fuel filter. Front fuel filter. Routine... nothing to note.

Went to execute the priming procedure (30 seconds with key to Run position 6 times) and something wasn't right. I was blasted with every possible idiot light on the dash and couldn't hear my fuel pump priming. Dash lights looked similar to those reporting the wiring harness / parking break issue where the dash goes nuts and you get a high temp, low oil pressure, service everything, put your seat belt on and your truck dies.... Luckily I was just in the garage.

Tried connecting to my EZ Lynk to see if I could see any DTC's but the EZ couldn't see the ECM.
Mechanic friend tried his scanner and it also could not communicate.

After a while, we found Fuse 33 (Vehicle Power 1) blown. This powers the ECM. (Friend looked up the one-line and pointed it out... said it doesn't power anything else).

Could anyone verify that Fuse 33 powers nothing other than the ECM? Assuming this is just an insane coincidence, and my maintenance had nothing to do with it, where would I start? I know I need to check grounding etc etc, but has anyone seen this? Anyone ever blow this fuse at all, ever?

I did replace the fuse a couple times. Attempt 1 I actually had the "wait to start" indicator show up and things were "normal" for a few seconds before it blew. Attempt 2 and 3 where instant fuse blows.

Before I have this thing towed out of my garage to the dealer, I am hoping someone has seen this.

1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.