Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hey everybody,been a while since I've been here.
No start situation this morning,checked the oil and it was low
Topped it off and got it started.
started driving and it "clicked off" but then kept running.
I thought it was sorted out, but by the time I got to the freeway every time i would try to accelerate it would Die
It would restart but would not accelerate
Got a Tow home and now Im trying to get a clue!!
Any help appreciated
 

·
Premium Member
Joined
·
2,397 Posts
How about you get a proper scan?

How many miles?

How old are the sensors?

Sounds like a cam sensor. Or could be an aging fuel pump.

Could be ipr / icp / hpop.




—————signature—————
~Don’t overthink something simple~
...:uptight people suck:...
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
So since I posted I went out and checked for voltage at the fuel pump
No Voltage
Not sure where fuse and relay are located
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
220,000 miles
changed cam sensor a while back
seems like the cause was low oil content because it did start and drive for a bit,just not sure why there is no voltage to the pump now
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
Doing some searching I found that my truck has a Fuel reset button on the passenger side kick panel
I put my finger in the Hole and there is a hard plastic box with a circle on top ,may be the button but there was no button action.
 

·
Premium Member
Joined
·
2,397 Posts





—————signature—————
~Don’t overthink something simple~
...:uptight people suck:...
 

·
Registered
Joined
·
169 Posts
Doing some searching I found that my truck has a Fuel reset button on the passenger side kick panel

I put my finger in the Hole and there is a hard plastic box with a circle on top ,may be the button but there was no button action.


It’s like a circuit breaker. It pops so if it already down it should be fine.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
Thank you,
I am not familiar with auto relays
Can it be reset like on a house breaker?
Is the Fuel relay under the dash?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #9
so yesterday I left the key on and the batteries are at 12 volts
put the charger on over night,they still read 12 volts
Batteries are not old
found the fuses box under the hood ,fuses are good ,not sure how to check relays
still no power to fuel pump
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
fuel pump relay location

E99 no power to fuel pump
found what I believe to be the fuel pump relay next to the E flasher behind the radio
Checked for power at the relay ,not sure if one relay or two, but the upper relay has power to it with key on, the other does not.
Starting to suspect PCM???

Problem started with low oil , no start situation.
Got it started after topping off oil but seemed like the fuel was cutting off after that, I got about 5 miles before it died all together

Also NO WTS light
any input greatly appreciated
 

·
Registered
Joined
·
656 Posts
No WTS light check fuse 30 under the dash
 
1 - 11 of 11 Posts
Top