Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
trans was slipping. had it rebuilt and it blew again. trans shop has rebuilt it 3 times now. they replaced all sensors and still has issues driving on freeway. they say it bangs in the gears when power is givin. would my ecm be causing problems that wont work with the new sensor box and trans???
 

·
Registered
Joined
·
77 Posts
I dont know who is doing the rebuilds but after 3 of them I know I wouldnt be going back there,my truck shifts hard to but my trans hasnt blown up from it, I had it rebuilt because the owner before me was backing up a large camper and cooked reverse,these trannys are to exspensive to keep having problems.do you drive it hard?is the trans cooler blocking up,im no tranny exspert but I think you may need a second opinion
 

·
Registered
Joined
·
32 Posts
my 96 7.3/e40d was plagued with hard shifts...after replacing everything related to speedo and brake lights i threw in the towel and brought to ford dealer. they cant do much diagnosis but after 15 hrs of trouble shooting the tech found a bad read on MAP and BPS reading zero. replaced Barometric Pressure Sensor ($189 somewhere in dashboard) and both readings went back to range. tranny is smooth as silk now even though my speedo is still whacked out. hopefully helps, i didnt know they had BPS or that it could affect shifting.
 

·
Registered
Joined
·
8 Posts
HELP! HELP! My 96 f-350 7.3 e4od suddenly started shifting hard from first use of day. Noticed the speedo and odometer are not working. Tranny OD light on gear shift blinking. No slipping drives normal, just shifts with a bang. Any one have any idea what could be wrong.:dunno:
 

·
Registered
Joined
·
32 Posts
You need a speedo working for truck to shift proper, speedo takes signal from rear end and converts it and outputs to computer to control tranny, you are in a limp mode and truck is shifting from tach only. It will give you whiplash!
 
1 - 5 of 5 Posts
Top