Ford Powerstroke Diesel Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter · #1 ·
Driving to work this morning doing 68 on the interstate. All of a sudden the motor dies. Radio, flashers, etc... all still work. I coast to the end of the exit ramp and try to restart the truck. Nothing. No turn over no noises whatsoever. Waited 15 min after calling tow truck, mechanic, and wife. Tried again and it turned over for 4-5 sec but wouldn't fire. Turned the key off and back on again and it turned over for 4-5 sec and fired. I drove the remaining 4 miles to work with no issues. I do have a security button. When I turn the key to the run position, I have to press this little button to start the truck. I thought maybe that thing was acting up.

Any other suggestions??
 

·
Registered
Joined
·
256 Posts
Did you checked all the fluids of your truck to see if everything are fine and a correct level? The 6.4L will not stall without a valid reason.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #3 ·
Yeah. All fluids are fine. All gauges are good. It runs perfect. I hope it was just the security starter was acting up.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #4 ·
Well. It ran fine for two days after that first incident. On my way to work this morning less than 2 miles from my house and it died again while I was going 55 mph. Pulled over on the shoulder. This time it would turn over but wouldn't start. After about 5 min, it wouldn't even turn over. This is the second time in a week. I have it at the mechanic now. Hopefully he can figure out what is wrong with it!!
 

·
Registered
Joined
·
533 Posts
Did you pull any codes with your mini max?
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #6 ·
how do you do that???
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #8 ·
It is at the mechanics right now. I don't have access to it. But i will relay the message to check the PCM ground.
 

·
Registered
Joined
·
108 Posts
Check your batteries. I had something like this happen to me about 2 months ago. I just got it back on the road. My truck just shut off exactly like your saying, i checked my codes on my SCT and cleared the one code, truck fired up, then shut off after backing up 10ft. My security module locked me out so i couldnt look at codes or do anything on my tuner. At the time i didn't know much about tuners so i called SCT and delt with them for 2 months sending them modules ect ect, they were no help. Took my truck to Innovative Diesel in MD.

What happened was one of my battery cables was shorting out, causing a surge. This shut down all of the computer modules in the truck to save them from being fried. When i cleared the code, they fired back up and i was able to start the truck, until the security module locked me out.

These trucks have miles of wire on them, but the first thing i would look at is to make sure all battery cables, and batterys are in good shape.

Just thinking out load for you..
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #10 ·
Well...couldn't find anything wrong with the truck at the mechanic's.

I do have a little button hidden in the dash that you have to push after turning the key to the run position. Then and only then will the truck start. Some sort of security thing.

Any ideas on what this could be? I want to have it removed, as that is the only thing we can think of that could be causing this problem.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #11 ·
When I got home, I checked the Mini Maxx trouble codes, I got:

P0578 - Cruise Control multi-Function Input A Circuit Stuck

P0232 - Fuel Pump Secondary Circuit High

P0284 - Cylinder 8 Contribution/Balance

If my injector #8 is bad, would/could that cause the shutdown??
 

·
Registered
Joined
·
1 Posts
I've had the same thing happen but did get a warning on the dash to pull over when safe. Mine was an exhaust sensor. After shut down would start again in 15 minutes and run. Was told it might run 5 minutes or five months I didn't chance it had it changed out the next morning.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #13 ·
My exhaust doesn't have the sensors. New down pipe and 5" exhause with DPF removed.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #14 ·
Well. Got the injector in yesterday. Checked codes on mini maxx and there were none. Drove home last night no problem. On the way to work today and it died again. Two codes: P0087 Fuel Rail/System Pressure Too Low and P0232 Fuel Pump Secondary Circuit High.

Please help!!!
 

·
Registered
Joined
·
322 Posts
i hate to hear your having issues. is your truck still under warranty?
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #16 ·
Of course not, I'm an idiot!!!

Instead of the warranty, I chose to do mods. Hoping to prolong engine life and make it more reliable. There was another $3K down the drain + the $800 I paid to have the #8 injector replaced yesterday.

Could the mods be doing this to my engine?

It was 25 degrees here this morning. I started the truck up and it started just fine. It sat and idled for 10 minutes to warm up. I drove it maybe 3-4 miles and it acted like it was running out of fuel. It wouldn't even turn over when I tried to crank it this morning.

I had it towed to a local dealer. We'll see....
 

·
Registered
Joined
·
858 Posts
That hidden button in teh dash is probably teh programing button for ur alarm.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #18 ·
I don't have an alarm.

I was told it was an anti-theft measure. You have to press that button or the truck won't turn over.
 

·
Registered
Joined
·
11 Posts
I had the exact same thing happen this morning, it threw the P0232 code, which from what I understand, means the fuel pump is not getting enough power to it (short/loose connection somewhere) or the fuel pump is going bad (that can be checked by checking fuel pressure when cranking, should be between 3 and 8 psi on the schrader valve on the fuel cooler)

The good news, however, is you can still start your truck when it throws this code. You need to clear the DTC 3 times, cycling the key on and off between each time you clear. Then it should fire right up again. It seemed strange to me too, but this resets something in the computer that allows it to try to start again. I've had to do this on two separate occasions and lo and behold, it works.

Also, my guess is that your injector #8 was not bad, it threw that code bc it was starved for fuel at the time your fuel pump was acting up. This is just speculation, maybe someone else can back this theory up, even though its a moot point now that you've already replaced it. Its just one less to go bad later on now!
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top