Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
774 Posts
Discussion Starter #1
I don't want to post this in the problem area since I don't know if it is actually a problem or just my bad luck.

I am on my second driver side battery, the first was replaced at 12K for leaking and now at 45K the new battery is now leaking. Keep in mind the passenger battery is fine. I was told even thought the battery is off the self it does not have the 3 year replacement and 7 year warranty, this is because Ford replaced it under the 3/36.

I thought I read somewhere that leaking driver side batteries was being noticed by other 6.7 owners. Just wondering if I am not the only one, next time your hood is up check it out. Not that it really matters, but if others are leaking I am going to switch to gel/glass pack batteries.

Thanks
 

·
Registered
Joined
·
251 Posts
I have had to have my drivers side replaced already as well..
 

·
Administrator
Joined
·
30,455 Posts
I would pull it and look for a badly placed bolt ETC
that would wear through the case

and a AGM or Gel would be ruined by the same situation
 

·
Registered
Joined
·
774 Posts
Discussion Starter #4
I would pull it and look for a badly placed bolt ETC
that would wear through the case

and a AGM or Gel would be ruined by the same situation
It is leaking on the top from under the two caps and positive terminal on mine in both cases. I also replaced the metal hold down bracket, which is also again corroding. :dunno:
 

·
Administrator
Joined
·
30,455 Posts
Hmm
that crazy / sounds like an overfill / overcharge??

but if the 6.7 is like the rest of the Power strokes both batts are tied together and receive the same charge ,, however that I can't confirm on the 6.7

Keep us posted
 

·
Registered
Joined
·
774 Posts
Discussion Starter #6
Hmm
that crazy / sounds like an overfill / overcharge??

but if the 6.7 is like the rest of the Power strokes both batts are tied together and receive the same charge ,, however that I can't confirm on the 6.7

Keep us posted
Or maybe it is just too hot in that part of the engine compartment? I really don't know. :dunno:

I will keep you posted and hopefully some other owners will check theirs and post the findings.
 
1 - 6 of 6 Posts
Top