Ford Powerstroke Diesel Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2006 F350 6.0L King Ranch with 203,000 miles on it. This draw has taken out 3 sets of batteries, alternator, FICM, and is driving me insane. Also, this draw has been seemingly getting worse for the past couple years. At first I just needed to jump it twice a year for what seemed was no reason, then multiple times throughout only the winter, and now the pickup is dead within 12 hrs whenever the batteries are hooked up. We tracked the draw back to the instrument cluster so we sent it off to get repaired by Circuit Board Medics. Just got it back two days ago and the pickup again drained the batteries and is again a yard ornament. We tracked it back to the instrument cluster by pulling fuses. We pulled two fuses for the instrument panel and the draw went away. We replaced the fuses and unplugged the instrument cluster and the draw went away. So we figured it was the instrument cluster and sent it off for repair. I thought it made sense because every now and again my cluster would go dead or the gauges would twitch until I gave the dash a slap and then it went away. I'm not really mechanically inclined but I'm trying to learn. Could the wiring harness in the dash be shorting out somewhere and that's the issue? Is there a way to test that? Or did they just not fix the instrument cluster? Or could I just be missing something else entirely? Any help is appreciated! :)
 
1 - 1 of 1 Posts
Top