Ford Powerstroke Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
I have several of thier HID kits in all of my previous and current vehicles but have never had to use their warranty till now. My 08 has had thier 55w hi/lo's in it for about a year and one of my ballast have quit working. I have sent 3 warranty tickets, called numerous times, and sent their general email a couple of emails about my issue. This has been 2 weeks now and still no response. Are they even in business anymore??? Does anyone know a better way to contact someone their?
 

·
Registered
Joined
·
74 Posts
I believe they are an eBay company. If you cant reach them, I am sure you can find a ballast for $40.00.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
This is ridiculous.. I even made a post on their facebook page. Called all numbers listed and have yet to hear from anybody.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Facebook post worked. Once you get to talk to someone they are actually good people... Was a email communication problem.
 

·
Registered
Joined
·
334 Posts
Getting ahold of them is the battle. Once you get someone on the phone it seems to work. I am still waiting for a 35watt ballast for the ones in my Rhino. They received them on 9/8. Says they are busy from Labor Day. I dont know. I hope it works out because I sent a kit in for a refund. They are very reasonable on prices but the service is lacking. Seems like they are way too small with too big in sales.
 

·
Registered
Joined
·
139 Posts
ive had nothing but problems with DDM, but they have takin care of all my problems quickly, i have heads and fogs in my truck and the heads have the extra harness to run off the battery, well the 20amp fuse in that harness completly melted in its housing. the housing was like it was brand new nothing wrong with it at all. I dont no how it melted and never popped. so i talked to ddm and they sent me a new battery harness but now this harness has a 30amp fuse. and before that fuse melter all my lights worked fine, now everytime i turn my highs on my 15amp fuse in the cab blows. anyone else have these this problem?
 

·
Registered
Joined
·
48 Posts
I just ordered a set of heads and fogs from them which were apparently drop shipped to me from China. The outer box as well as the boxes inside look like the were drug all the way from China to Texas. I should have not even tried to install them. One fog ballast and one head ballast seem to be out. (Problem follows the ballast)

I will be contacting them on Monday for a refund. :dunno:
 

·
Registered
Joined
·
42 Posts
Discussion Starter #8
Once I did get intouch with someone my problem was handled very fast. Even had the manager contact me to check on what was up. Mine came direct from them and in great care when I bought. I hope you get your issue resolved.
 

·
Registered
Joined
·
48 Posts
Still no luck here. Some of the worst customer service I have seen.

They one time I did get someone to answer the phone the girl took my number and said they were busy and would call back.

Still have a none working head a fog set in a box that looks as though it was drug behind a truck drop shipped from China.

DDM is a joke.............. BUYER BEWARE

edit..... And no, I do not have a FB account, never wanted/needed one and certainly do not feel like I need one to contact someone to honor their product. I certainly did not need one when it was time to purchase.
 

·
Registered
Joined
·
1,358 Posts
i ordered and installed 55w 8000 heads and 55w 8000 fogs. mine were shipped straight from china as well. all installed fine....and have been trouble free.. i dont know how everyone has installed theirs but it should be powered direct from the battery using your existing headlight socket as a switch to fire the ballast...nothing else runs through the factory set up... this could be where some are experiencing issues..:woot:
 

·
Registered
Joined
·
77 Posts
I have their 35w 5000k hi/low and fogs and everything went smoothly, except that I had to wait about three weeks for it to ship because the bulbs were on back order. The only problem I have is that the fogs are too bright! I can't leave them on when I approach oncoming traffic. People always flash their lights like I have mine on bright. Is there any way to adjust the fogs to keep this from happening?
 

·
Dont Mess With Texas!
Joined
·
5,788 Posts
i have DDM 55w heads and 35w fogs, although the box was beat up when i got it, they work excellent and anytime i have ever called customer service i was on the phone and back off in less than a few minutes
 

·
Dont Mess With Texas!
Joined
·
5,788 Posts
1 - 14 of 14 Posts
Top