Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2,535 Posts
Discussion Starter #1
Well I re-installed the DPF and returned the truck to stock today...because it's going to the dealership for the intercooler update and to have the tranny looked at. In 40 miles, the DPF never went into regen, and the truck seems weak. Also...when I was going to walmart just now, the CEL came on and it was a P0401 code...(Exhaust Gas Re-circulation Insufficient). Anyone else had this issue when they returned to stock? I'm thinking the EGR valve is plugged and maybe the DPF is too?

Hopefully the dealership finds this issue and addresses it..
 

·
Registered
Joined
·
1,640 Posts
Ya your egr valve is stuck that's why it seems weak same thing happened to my truck. It's because you were most likely running a tune that didn't cycle the valve. Not a big deal the dreamer ship will see that and put a new egr valve on.
 

·
Registered
Joined
·
1,025 Posts
EGR valve is stuck needs service. Still under warranty ? If so let the dealer service it. If not removing and cleaning will fix and clearing codes nobody will know. Search the form for the how to details several with pictures. Another good source Diesel Technician Society
 

·
Registered
Joined
·
2,535 Posts
Discussion Starter #4
Ya it's still under warranty...I only have 50k miles on it. I cleared the code with my H&S and set the truck back to bone stock. I've been lettin it idle in the drive way the past half hour trying to get it to throw the code again or get the valve to cycle...going for a test drive soon. I wish I could just delete the damn thing LOL
 

·
Registered
Joined
·
1,640 Posts
Just drive it then the code will keep coming back I kept clearing mine and about once a day it would come back
 

·
Registered
Joined
·
72 Posts
Same thing here. Put mine back to stock yesterday for the 2nd radiator leak. Same code. I though all of the H&S tunes cycled the EGR:dunno:
 

·
Registered
Joined
·
1,378 Posts
Same thing here. Put mine back to stock yesterday for the 2nd radiator leak. Same code. I though all of the H&S tunes cycled the EGR:dunno:
Only the "easy" tunes function the EGR.
 

·
Registered
Joined
·
72 Posts

·
Registered
Joined
·
2,535 Posts
Discussion Starter #9
Well I got the truck back today. My tech cleaned the EGR Valve and changed the intercooler. He said I had a "pool" of water at the bottom of the intercooler, and the updated one isn't considered a "fix" but he hasn't had anyone in the past year and a half come back after having the updated one installed. Of course...the tranny didn't act up at all since I've been de-tuned...makes me think the H&S is bad JuJu
 

·
Registered
Joined
·
72 Posts
Well I got the truck back today. My tech cleaned the EGR Valve and changed the intercooler. He said I had a "pool" of water at the bottom of the intercooler, and the updated one isn't considered a "fix" but he hasn't had anyone in the past year and a half come back after having the updated one installed. Of course...the tranny didn't act up at all since I've been de-tuned...makes me think the H&S is bad JuJu
Yep, my trucks tranny slams sometimes.... Often I should say, maybe 1-2 a week, which is too often for me. Don't think the tuner is going back on. Been driving it on the no power tune(50) for a week now anyway....
 
1 - 11 of 11 Posts
Top