Ford Powerstroke Diesel Forum banner

1 - 14 of 14 Posts

·
Click Click.......BOOOOM!
Joined
·
329 Posts
Discussion Starter #1
Has anyone had this problem my truck is throwing P0683 Cylinder 8 Glow Plug Circuit. Is this a serious problem or just a loose connection? Any help would be great. Thanks
 

·
duct tape & zip ties
Joined
·
10,761 Posts
Could be faulty connection, could be a bad glow plug. Only way to find out is to remove the valve cover and take a look.
 

·
Registered
Joined
·
4,057 Posts
Could be faulty connection, could be a bad glow plug. Only way to find out is to remove the valve cover and take a look.
Ditto. We can't tell that either. Go take a look. :nod:
 

·
duct tape & zip ties
Joined
·
10,761 Posts
pull the valve covers for what? the glow plugs are below the valve covers
Yes they are. You have to pull the valve cover to check the glowplugs. Just to you let you know. Your injectors are under the valve cover too.


The problem maybe the under valve cover wiring harness. It maybe the connection on the outside of the valve cover. It could be a bad glow plug.

But the only way to find out is to pull the valve cover off. Check the wiring harness, pull the glow plug and check the ohms on it.

Don't worry the valve cover gasket is reuseable.
 

·
Registered
Joined
·
3,720 Posts
Yes they are. You have to pull the valve cover to check the glowplugs. Just to you let you know. Your injectors are under the valve cover too.


The problem maybe the under valve cover wiring harness. It maybe the connection on the outside of the valve cover. It could be a bad glow plug.

But the only way to find out is to pull the valve cover off. Check the wiring harness, pull the glow plug and check the ohms on it.

Don't worry the valve cover gasket is reuseable.
just so you know, they are NOT under the valve cover.

i just had my vc off sunday to check an injector.

the glow plugs are below the vc with its own harness. nothing glow plug related is under the vc

on my 03 i have a bus bar harness that has a connector up by the front of the motor. a deep socket 10mm will take the glow plugs out WITHOUT removing the vc. on the newer truck its a split loom harness. the glow plug connectors go into the rocker box like my 03 but with a different harness
 

·
duct tape & zip ties
Joined
·
10,761 Posts
just so you know, they are NOT under the valve cover.

i just had my vc off sunday to check an injector.

the glow plugs are below the vc with its own harness. nothing glow plug related is under the vc

on my 03 i have a bus bar harness that has a connector up by the front of the motor. a deep socket 10mm will take the glow plugs out WITHOUT removing the vc. on the newer truck its a split loom harness

So on a 6.0 they are outside of the valve cover.
 

·
Registered
Joined
·
3,720 Posts
yes, they actually have their own port on the rocker boxes.
correct. i just edited my post at the end.

ill post up some pictures tomorrow. my camera died as i was going outside to take a picture.
 

·
duct tape & zip ties
Joined
·
10,761 Posts
Ok I thought they were like the 7.3L my bad.
 

·
duct tape & zip ties
Joined
·
10,761 Posts
yeah my next post was going to say you know this is a 6.0 motor problem not a 7.3 right :hehe:
Ok so I had the location wrong. But the problem would be the same. Either wiring or the glow plug itself.
 

·
Registered
Joined
·
597 Posts
from what i hear, actuall glow plug failures on 6.0 are rare. Usually either harness contaminated with oil. or the glow plug module is toast.
 

·
Registered
Joined
·
597 Posts
BTW cylinder 8 is the driver side rearmost (closest to firewall) FYI...
 
1 - 14 of 14 Posts
Top