Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
My cruise control suddenly quit working along with my window washer sprayer on the driver side. I have a 2001 F350. Any suggestions? :dunno:
 

·
PMR = JUNK
Joined
·
11,263 Posts
Did ya check all your fuses?
 

·
Registered
Joined
·
1,744 Posts
Mine did that and a wire in the door panel had been cut in half by the window a simple wire connector would have fixed the problem if i cought it sooner, but the spark started arking and then blew my door lock actuators and window motor, i would check it quick
 

·
Registered
Joined
·
1,744 Posts
yea it is. it really sucks
 

·
Registered
Joined
·
110 Posts
My cruise and horn quit working at same time - from searching I've seen that it's likely the "Clock Spring" in the steering column. The clock spring is a round collar near the top of the column that has a coil/uncoil ribbon wire in it.

Nevada, was thinking that since you had something else activated in the column (washers) go out at the same time that maybe the clock spring is your problem too.


1. I can hear a click near the steering wheel when I try the horn but that's all, this is just the horn relay.

2. How hard is the clock spring to replace? (I have had some of it apart already when I replaced the cruise switches (only $40 at directfordparts.com, but that wasn't it :doh: )


Here is a link to a diagram showing the clock spring on a 2000 F350, I think it is about $80 list.

steering column diagram


Other info I got from searching about cruise fixes:

1. Make sure your brake and backup lights are working.
2. Make sure the little switch your emergency brake lever hits when you release the brake is getting tripped and is working. If your emergency brake light stays on the cruise won't work.
3. Check the pressure switch located on the master cylinder.
 

·
Registered
Joined
·
110 Posts
Well, I don't know if it took the computer a while to figure it out or what, but after getting my emergency brake switch working, which at first, did not fix the cruise, now the cruise is working great.

Edit 5-30-08: Actually, about a week later, the cruise quit again, so I am suspecting the "clock spring" again. Odd thing is, my emergency brake switch was stuck in the OFF position, so the emergency light was not ever coming ON, so you would think this would not effect the cruise, but now that I cleaned the switch and have the light going ON and OFF correctly, the cruise is working. Horn is still not working though.

I am going to replace the emergency brake switch because the little head of it seems to be broke off from the post, although after cleaning it, it seems to work.

Edit 6-4-08: Now I have replaced the switch, but cruise not working, checking into what it takes to replace the clock spring.

EDIT 6-15-09: Replaced the clock spring, did not fix cruise or horn. It was only about $70, new one is updated part # and looks like a new design, I've heard they go out a lot anyway.

EDIT 6-26-09: REPLACED THE HORN RELAY, FIXED THE CRUISE. PUT OLD RELAY BACK IN, NO CRUISE. PUT NEW RELAY BACK IN, CRUISE WORKS. HORN RELAY IS IN FUSE PANEL UNDER LEFT SIDE OF DASH. If I remember right, it's the 2nd relay down on the left in your under dash fuse box. In your manual, in the fuse section if you go to the very bottom of the chart they list the relay locations.

I SUPPOSE BOTH THE CLOCK SPRING & THE HORN RELAY COULD HAVE BOTH BEEN BAD.

NOTE: My horn has never worked and it blows the fuse in the panel under the dash. Horn still does not work, but the cruise now does. Going to pull the horns next.

EDIT 12-22-09: After replacing the horns, I have now figured out that if your horn contact under the airbag is stuck on, that your cruise will not work. The stuck horn contact also causes the horn relay to heat up and go bad and the cruise would not work with a bad horn relay in there.

Here is a link to how I fixed my sticking horn contact: http://www.powerstroke.org/forum/99-03-7-3l-general-discussion/125167-sticking-horn-contact-fix-dont-need-new-airbag.html

So, you see, all the intermittant cruise working/not working stuff was related to my sticking horn contact which I did not know was sticking because my horns were bad. I thought maybe that when you honk your horn it is supposed to stop the cruise, but now that I have everything fixed that is not the case, so not sure WHY the sticking horn contact stops the cruise, but it causes some kind of issue, especially if it's stuck on and your horns aren't working or if the sticking horn contact causes the horn relay to go bad.

And, by the way, since a sticking horn contact pulls in the horn relay and holds it (with bad horns, no sound) then, in about 10 days, the batteries get run down.

Another ironic thing about it is that a horn that doesn't work causes people to push the horn button even harder.....which is what causes the horn contactor to fail.....thereby adding another issue causing the horn to not work.

So, to replace the horns, after taking them out, first make sure they are bad by checking with a separate power source....I used a battery charger, but you could connect them direct to the truck's battery too.

1. The horns are up under the front of the passenger side wheel house. Take out the various front and center wheelhouse bolts, screws, and push in clip(s). Pull the front of the wheelhouse down and hold it with a strap or let a helper hold it. The wheel house will bind on the inside edge of the fender and probabaly bend this edge a little, you can tap it back into place with a hammer handle or plastic hammer when you get the wheel house back in place.

2. Take out the battery, then there is only one bolt holding the whole two-horn assembly - the bolt is about even with the front edge of the battery, but the battery is in the way enough that it is easier just to take it out.

3. The new horns come with a bunch of adapter type stuff you won't need, just reuse your old wire connectors and mounting bracket, but the contacts on the new horns may not be in the exact same place as your originals, but it all ends up pretty close to original, just make sure the wires don't end up in a position where they are going to get rubbed through. Also, note the horns are marked "H" and "L" for high and low tones, keep them in their original locations on the mounting bracket. I think the horns were around $75 for the pair, but the Ford parts guy gave me a deal, I think you are talking around $95 normally but can't remember for sure.

Well, I may have replaced some parts I did not need to, but at least I have them in there and the overall price was still way cheaper than having the dealer fix it, especially if you figure the horns and the cruise are now both fixed....heck an airbag alone is $500+ at the dealer plus labor, they probably would have put in a new airbag to fix the horn contact.
 
  • Like
Reactions: Berto
1 - 8 of 8 Posts
Top