Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
ok so ive had this prob on an off for a month or so now, it will just crank an crank an crank , normally i would just crank it for like 20 seconds the oil preasure gage would jump to the middle then right affter that it would crank up, well it aint done this in a couple weeks now so i forgot about it till last night well it did the same thing cept this time affter the preasure jumped my dash flashed tbc fault an would not start well we let it sit for bout 3 hours went back started up no prob, well today it happened again right affter i got my oil changed i couldnt get it to start, well i really didnt have time to leave it , an i know your not supposed to do this but i was pressed for time we sprayed a lil starting fluid into the intake an within bout 5 seconds it started up, so does anyone know whats goin on with this thing, sorry for the length
 

·
Premium Member
Joined
·
2,584 Posts
Sounds like a low ICP pressure concern to me. If you have less than 100,000 miles this should be covered under Ford's diesel engine warranty coverage.
 

·
Registered
Joined
·
1,509 Posts
Certain years were affected by a problem with the STC fitting on the HPOP. Now, I am going to guess that yours may have this problem, because there were many affected units it seems in that year range. The symptoms of this problem, were hard hot restarts, eventually leading to a no start situation, and sometimes the trucks would stall once warmed because the oil gets hot and becomes thinner, leaking more.
 
1 - 4 of 4 Posts
Top