Ford Powerstroke Diesel Forum banner

61 - 62 of 62 Posts

·
Registered
Joined
·
1 Posts
so what was the solution currently battering the same issue have replaced ipr icp and ficm hear what seems to be an air leak at the fuel filter housing but it stops 10sec after the pump primes have yet to air test the hpop but it was recently replaced at dealership. Possible air leak just curious on what the solution was we have had it hooked up ipr shows good pressure icp only shows 150 will not go over. Replaced ficm and truck ran but would cut out and throw codes for random injectors and crank/cam position sensors
 

·
Registered
Joined
·
115 Posts
Discussion Starter #62
I have been super busy with renovating my house so I actually forgot to post an update...

I ended up driving the truck about 50 miles from my parents house to my house and the truck smoked at first then actually ran pretty decent. I took it really easy though. Got the truck home and it actually starts pretty good now. Just started it now after sitting for about 2 weeks and it fired right up in about 2-3 seconds. The truck definitely needs injectors and a few things like the green coolant flushed out, so I really haven't been driving it. Its an extra vehicle for me at the moment so I haven't wanted to spend the $1400 on injectors quite yet.

To sum it up I think my issue was that the top orings on the injectors were blown out and possibly had leaking nipple cups on the oil rails. I have a feeling I fixed the issue after replacing those but didn't drive the truck long enough to work all the air out. I made this worse by prioritizing the starting issue before the injectors. Since the truck did start I should have replaced the injectors then diagnosed the hard start.
 
61 - 62 of 62 Posts
Top