Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I just finished doing some preventative maintenance on my late 04 EX. Coolant system flush w/ Fleetguard and VC-9, new oil cooler, updated dummy plugs/standpipes, IPR coolant filter, EGR plug, and GEN2 EGR cooler delete. I got everything back together and cranks but no start. I cycle the key to prime the fuel. I crank for 8-10 seconds and stop, then try again. Am I not cranking long enough to get the oil pressure up? TIA.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #2
Got it started but now is hard to start. 4-5 seconds before it fires and code P2284. Could the new standpipes/dummy plugs be an issue?
 

·
Registered
Joined
·
4,914 Posts
Got it started but now is hard to start. 4-5 seconds before it fires and code P2284. Could the new standpipes/dummy plugs be an issue?
Check icp connection. Run it to get the air out of the system. Let us know if the code comes back.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
Check icp connection. Run it to get the air out of the system. Let us know if the code comes back.

Sent from my phone that somebody didn't help me get.
Drove it to the doctors office this morning. Starts up fine now, actually faster than before. Like you said just needed to run the air out of it. Thanks for your help.
 

·
Registered
Joined
·
4,914 Posts
Good to hear.

Sent from my phone that somebody didn't help me get.
 
1 - 5 of 5 Posts
Top