Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
ok so heres whats goin on, every now an then affter i would drive for a lil while an shut it off it would not start back up , now affter about maybe an hour or 30 mins it will fire up now, i havent had to much problems when its cold it seems to happen more when its hot, now yesterday i got stuck at the carwash after 20 mins it started up, now all day its been doin it, i went to walmart went in came out started no problem got home an it sat for about 20 mins an wouldnt start came home like 3 hours later an it started , ran up to the gas station, tried to leave it on but they yelled at me, she had only been runnin like 5 mins, shut her off, an of course it wouldnt come back on it would just crank i sat there for like 30 mins tryed it again still nothin, tryed again 5 mins later this time i went for about 15-20 seconds just as i was letin off the key the oil pressure gage shot to the middle were it normally is, so i waited a min an tryed again same thing 20 seconds soon as the needle jumped i pressed the gas an away she went, an i apoligize for the length of this post, is there anything i can check, i imagine tommorow im goin to the dealer an havin them look at it but any info would be great im tired of getin stuck at random locations, try bein stuck in a carwash....kinda embarising
 

·
Premium Member
Joined
·
9,390 Posts
the fitting on the back of the high pressure oil pumpis more than likely what the problem is on an 05 model, oil is thicker cold and starts ok, get hot gets thin and engine loses pressure , after cools , starts , sounds exactly like high pressure oil pump fitting , there is a updted bracket for that problem
 

·
Registered
Joined
·
178 Posts
Discussion Starter #3
i apreciate the quick response, i just hope no mater what it is i dont have to goto long with out my truck .
 

·
Registered
Joined
·
119 Posts
Bracket kit, takes me about 4-5 hours and your done.
 
1 - 4 of 4 Posts
Top