Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
I have 2 new ford batteries. Parked the truck and in the morning, no battery. I thought it would be the 3rd GPR going bad again so I installed the new Stancor and I have not been able to charge my batteries yet but I had some power left for interior lights, and I noticed a strange clicking sound. It is coming from in front of my right knee under the dash. So when I laid down I saw a box with 3 plugs plugged into it. I was wondering if there is another way to trouble shoot or , what is this box for or do I have to wait to get my batteries charged. either way.

Please help I am parked on the street and I do not want to go crazy like last time and get new batteries.... I also have a bad flywheel tht likes to free spin every 7 start-up.... So I did change the Starter last week and thats how I saw the chip marks on the flywheel.
 

·
Premium Member
Joined
·
9,603 Posts
you have a short somewhere. The clicking sound coming from the dash is the fuel pump relay. I had this exact same problem not long ago. Double check that all you battery connections are making good contact and are tight. Also check the cable's themselves. Mine turned out to be a bad cable that was grounding out.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #3
Installed 2 new batteries and the same reaction no cranking and all juice is gone and relay starts to click and interior light goes out. ? Help Anyone???
 

·
Registered
Joined
·
110 Posts
Discussion Starter #4
can a new strter gone bad do this?
I will check all the cables!

Thanks
 

·
Registered
Joined
·
119 Posts
Check for a ground somewhere, noway its the batteries after that many times.
 
1 - 5 of 5 Posts
Top