Ford Powerstroke Diesel Forum banner

1 - 20 of 42 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
Supposed to be an easy drive home from the office today. Exited the freeway after doing 75-80MPH and pulled in my neighborhood to head to the house with no issues. Noticed at the first stop sign, that my ECT was 210* my EOT was at 205*. It was 100* today so not too worried my temps were up a bit. As I pulled away from the stop sign I could hear my fan kick on. Within a minute I had a coolant smell in the truck and actually had coolant splash my windshield from below the hood and came out the front of the truck and splashed the top of the hood. My EOT dropped from 205* to 190* then went right back to a normal 199ish. My ECT kept within 10* the whole time. My house was only a couple of streets away and in that short distance nothing seemed wrong with the truck. No loss of power, no crazy gauge readings, just a very strong/sweet coolant smell in the cab.

Once I got out I popped the hood, and it literally looked like a coolant balloon blew up in the engine bay. Figured my degas cap blew off...nope...my degas bottle (cap still on) was the ONLY item under the hood not covered in coolant. There was a puddle of coolant on the plastic cover above the radiator, coolant on the hood, coolant on my front bumper, coolant on the turbo, on the passenger side, driver side, both batteries, every nook and cranny on the radiator, etc...everything. Coolant was dripping out pretty steady from below the truck as well. Biggest puddle was next to the driver side wheel well, but it was coming out everywhere. My degas bottle is bone dry as well. I then assumed I had a busted hose, checked the hose from the degas to radiator, hose below degas, coolant filter lines, main line at bottom of radiator, all the hoses are in great shape.

I have had the truck a couple of years, and have had the oil and EGR coolers replaced a couple of times. The most recent change was less than 10K miles ago.

Not even sure what to check next. With the coolant being everywhere, I have to think it hit the fan, and just was splashed around. My next assumption is the radiator busted. I have never had a vehicle with a busted radiator, and not sure how to check. Any ideas to check if my radiator is still good? If not the radiator, any ideas what else it might be? Everything looks to be in good shape, little blue hose on EGR is still intact, EGR valve is still in place, no holes in any hoses. There is no way a pinhole could spray that much coolant, right? Thanks for any help. Looks like I found a great way to spend my Saturday.
 

·
Compression Ignition Addict
Joined
·
7,079 Posts
Fill the coolant system, pressurize the degas bottle to 10 psig, check for leaks. If you can regulate an air compressor to 10 psig, then tee it into a vapor hose going to the degas bottle (probably should use the one off of the radiator).
 

·
Registered
Joined
·
1,228 Posts
I would say your radiator cracked. Mine cracked while going down the road and everything including the side of my truck was covered in coolant. Mine cracked right under where the upper rad hose goes in, I didn't have to look very long to find it.
 

·
War is the answer!
Joined
·
5,386 Posts
Probably your radiator is cracked but you want to make sure. Let me know and I will send you the link for the upgraded all aluminum radiator for like $213 shipped no tax. It's a great deal and a beautiful radiator.

Sent from my SGSIII running a custom ROM.
 

·
Registered
Joined
·
108 Posts
Is that the one on ebay,if so that's the same one I just put in.
 

·
War is the answer!
Joined
·
5,386 Posts
Is that the one on ebay,if so that's the same one I just put in.
Yes, from leadersport?

Sent from my SGSIII running a custom ROM.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #7
Probably your radiator is cracked but you want to make sure. Let me know and I will send you the link for the upgraded all aluminum radiator for like $213 shipped no tax. It's a great deal and a beautiful radiator.

Sent from my SGSIII running a custom ROM.
Thanks for the responses. Just got back from morning errands and picking up some coolant. Going to start filling her back up to see where the leak is.

WarChild, definitely send a link over. How long did it take to get the radiator after you purchased it? How long did it take you to drop the new radiator in?

Thanks again for the responses.
 

·
Registered
Joined
·
108 Posts
It took me 7 days from ca to md.It should only take a couple hours to change.
 

·
War is the answer!
Joined
·
5,386 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #10
Thanks George for the PM and WarChild for the link.

These look identical to the alum radiator that BulletProof sells. Did either of you guys consider the BP one? My biggest reservation looking at the one on eBay is that is only has a 1 year warranty. Is that the norm?

Last question, other than a flush, is there anything else I should be doing proactively when replacing the radiator?
 

·
Registered
Joined
·
108 Posts
I believe if it doesn't leak in a year it probally never will, besides it's probally made by the same company.
 

·
War is the answer!
Joined
·
5,386 Posts
I did look at them but could not pass up the $213.

Sent from my SGSIII running a custom ROM.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #14
Do the 03-07 all use the same radiator? I have an 06 and want to make sure before I order. Shot the eBay seller a question, but haven't received a response yet. Everything I am reading says Ford used the same radiator from 99-07.

Found the crack this morning. It is bubbling out at the top of the radiator on the front of the truck at the base of the plastic housing. I had never noticed any part of the radiator was plastic...that really does not make much sense. Have an extra thermostat sitting around that I am going to put in as well. Have a neighbor telling me to go ahead replace the water pump while I am in there, so I am throwing that idea around. Any suggestions?
 

·
Registered
Joined
·
1,228 Posts
When I replaced my radiator I went on ahead and replaced water pump also. The reason that I did is because I would be kicking myself in the a$$ if 2 months later I had to tear it all back apart to change water pump when I was just there.
 

·
War is the answer!
Joined
·
5,386 Posts
The radiators are the same 03.5-07.

Sent from my SGSIII running a custom ROM.
 

·
Registered
Joined
·
192 Posts
The support in this forum is fantastic!
 

·
Registered
Joined
·
225 Posts
Discussion Starter #18

·
War is the answer!
Joined
·
5,386 Posts
It is a great forum.

Sent from my SGSIII running a custom ROM.
 

·
Registered
Joined
·
1,191 Posts
On my 06 I can see a little seepage around the top tank gasket on the radiator ...vs having it resealed and crimped is it worth just replacing?

I don't want to run into oil cooler issues as my deltas are good but I want to get away from ford gold.

Sent from my Motorola Electrify using AutoGuide.Com Free App
 
1 - 20 of 42 Posts
Top