Ford Powerstroke Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
My truck has recently developed a problem starting when left to sit for a day or so, I have been leaving the block heater plugged in and it starts fine, but am afraid to do any camping with the camper we just bought. New Hpop, ICP, IPR, and both CPS's. It does puff out a bit of white smoke when it starts, but it has pretty much done that since day one. 04, 170K mi. Thanks for any help.
 

·
Registered
Joined
·
4,222 Posts
Check your glow plug system. Run a compression test on your cylinders. Any codes?
 

·
Registered
Joined
·
420 Posts
Check your FICM.
 

·
Registered
Joined
·
4,914 Posts
Load test batteries, check ficm.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
sorry for the late response, ive been working. i will check the ficm voltage. i think there is a post on here explaining the proper procedure i noticed it wont buzz the injectors unless it is up to near operating temp. it will start fine after its been running. The FICM is about the only thing I havent replaced on this truck. Any suggestions on who does the best rebuild or new unit? Upgrades? Thanks again for all of the help you all have given me on this money pit over the years.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
Dannyboy my buddy is gonna bring his AutoEnginuity setup home from work to pull codes next week and I will let you know what we find out. Thanks for the reply.
 

·
Registered
Joined
·
4,914 Posts
Ficmrepair.com

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #9
Finally got around to testing ficm voltage. 47.6 KOEO. 15.3 while cranking. Im sending it to ficmrepair.com and will post the results. Thanks
 

·
Registered
Joined
·
11,152 Posts
What do your batteries do when load tested individually?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #11
The batteries load tested fine. Alternator seemed like it could be doin better under load, but the batteries are twelve plus before cranking.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #13
got the FICM back frrom ficmrepair.com added the Atlas 40 tune. Installed tonight and the truck cranked over twice and fired right up. It wasnt plugged in since I sent the FICM out for repair. Back to runnin like a champ. Thanks to all for the help and ficmrepair.com for the great service.
 
1 - 13 of 13 Posts
Top