Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 1997 PSD 2X4 CC 4EOD 84K 3" DP 6637 Napa intake 74*FP other than that it's bone stock.I replaced all 8 of the GP's as 2 were dead. VC Gaskets looked good as did the UVC harnesses. Buttoned it up and it threw a CEL that was the above codes which are: GP Monitor Fault Bank #1 & #2

Went back in and closer inspection I found burned connector on one of the VC gaskets. Both gaskets as well as all four UVC harness replaced, all outer connections inspected closely and connections through UVC were checked with an ohm meter. Buttoned it up and get CEL, same problem. Only thing left is the GPR so I replaced it (All parts are Ford) all connections have been cleaned and polished. Clear the codes and all is well, I drive around and really get it warmed up made several stops, fires right up, no code, park it for the night. Next AM Start it up, CEL same codes.

Check wiring diagram of GPR (Wish I knew how to include it but I don't)
Top of the GPR there are two (2) large posts Drivers side goes to starter relay and the other to the shunt that feeds the GP's.

There are two (2) other smaller terminals "B" to test pin #101 and "A" (Top) to fuse #22. Ford Mech tells me that during KOEO GP energized I should have 12V on both "A" & "B". I removed the wires from the GPR and I did have 12V on both "A" & "B".

Hooked the wires back up and again do the same test and I have 12V on "B"
but only 6.35 on "A" I have lost approximately 5V's. Ford says there should be 12 volts at both A & B at all times.

QUESTION:
How do I find test pin #101 or better yet....Where is it? I followed the harness to the driver's side where it plugs into another harness which in turn connects to another harness.

I have also been told that the drop in voltage is because "A" goes through a coil prior to the ground in the computer.

Clear the codes, warm it up and it runs like hell let it get cold, CEL Time.

Any and all suggestions are welcomed with open arms. I need to find the solution before I go to plan C which entails a large amount of C-4.

Thanks in advance,
Roger
 

·
Premium Member
Joined
·
5,441 Posts
:bump: :bump: :bump:
 

·
Administrator
Joined
·
9,390 Posts
there can be two things you have going on here , one being a wiring issue between the glow plug relay and the pcm on the two small wires, like corroded wires chaffed wiring or to me the most likely problem being a internal fault in the pcm, the pcm takes engine oil temperature reading and sets glow plug on time make sure that the glow plugs are staying on a decent amount of time ,if you find that the actual glow plug on time is 10 seconds when its 30 degrees and they should be on for 60 seconds thats not right and that would be a correlation isuue inside the pcm, if you find there are no wiring issues ,may want to look at replacing the pcm, pcm are few and far between that they go bad but they can, make sure also the fusible links that are on the 12v all the time side of the glow plug relay are good , just because its says twelve volts doesnt mean that the wires can carry the amperage there is a big difference in volatge and anperage or load the wirs are carrying
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Scuffy,
Thanks for your time and opinion and I concur with everything that you have said. There are a couple of things that I don't understand from a pure dioagostic stand point.

1) Where is this oil temp reading taken from, is this performed through a sending unit, or a probe? If these objects exist they may be the culprit.

2) Where is and how do I find "PIN # 101" whick is the other end of the small
wire "A" that is losing approximatly 5Volts during GP "On time"?

3) Should I be getting this 5Volt drop during GP on time? Ford says No! So that brings me back to Question #2: Where and how do I find Pin # 101?

4) I need someone with a '97 PSD to check the voltage on their rig to ascertain if during GP on time if terminal "A" drops 5 volts.

FYI, via the volt meter my GP on time is approximatly 45 seconds min.

Thank you so much for your help,

Roger:beer:
 
1 - 4 of 4 Posts
Top