Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey guys so I’ve got a 2000 dually 6 speed 2wd, I’m getting a pretty loud clunk that’s got me worried. It happens Under heavy acceleration, deceleration using engine braking when the clutch grabs, when I let the clutch out too quickly from a dead stop and even when I made a slightly aggressive right hand turn last night. I have changed all fluids, new u joints and greased the slip yoke with some general purpose grease I had laying around. Any ideas?
 

·
Registered
Joined
·
8,632 Posts
Check sway bar end links

check body mounts

check track bar bushings and upper track bar mount to frame

check drag link and steering bars to each side

check carrier bearing if you have a two piece rear drive line

When you greased driveline did you remove and then make sure the u joints are still lined up when re assembled?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
I had the clunk before I did the u joints and afterwards it went away for about 2 weeks and now it’s back, everything seems to be lined up
 

·
Registered
Joined
·
699 Posts
I had the clunk before I did the u joints and afterwards it went away for about 2 weeks and now it’s back, everything seems to be lined up
What did you use for U joints?

Who installed them?

Did you loose the needles out of one of the caps?

Did one of the caps get broken/cracked?

Did you hammer them in or press them in?
 
1 - 6 of 6 Posts
Top