Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter #1
I just removed my FICM and i broke a clip on the middle plug :eek:hnoes:. Any ideas on if it will be ok or on how to fix it or do i need to replace the whole darn thing? Thanks for the help.
 

·
GET MY ENEMA BUCKET BRO!!
Joined
·
2,068 Posts
I think you have to buy a new truck.






























Ficmrepair.com. talks about the what if in the faq I believe.
 

·
GET MY ENEMA BUCKET BRO!!
Joined
·
2,068 Posts
I broke one of the connectors when removing the FICM. What can I do?

If all that broke is one or both of the clips that ensure that the plug doesn't work itself loose, many have had good luck using heavy duty zip ties around the module to keep the plugs fully seated. Others have had luck taking a maybe 10" section of radiator hose, sliting it length wise and installing it under the module as a way to press the plugs continually back in. If your damage is more severe or you just want the 'right' solution, there are two options. The first is a replacement harness, but be prepared for some sticker shock. The injector harness (the plugs nearest the front bumper) retails in the $200 range and the ECM harness (the plug closest to the firewall) is closer to $800. Alternatively, you can try replacing the plug ends. A great write up can be found here
 

·
Registered
Joined
·
4,914 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter #5
HOLY CRAP! Thanks for the help.
 

·
Registered
Joined
·
4,914 Posts
At your service..........hehe. Welcome.

Sent from my phone that somebody didn't help me get.
 

·
GET MY ENEMA BUCKET BRO!!
Joined
·
2,068 Posts
You just took all the credit. That is so not cool. :p
 

·
Registered
Joined
·
4,914 Posts
You just took all the credit. That is so not cool. :p
Lol, well, I did answer his question.

Sent from my phone that somebody didn't help me get.
 
1 - 8 of 8 Posts
Top