Ford Powerstroke Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
1 Fresh battery (week old) other batt has NO bad cells @ 12.60
truck does start, Gp's working , WTS light works which sugguests 2 me PCM good. 3rd new alternator within 2 weeks, I even upgraded to the $175 model, still 110a. Despite all that NONE of these alternators have put out more than the battery voltage. all places around here (4) say their alternator testing machine broken. I do trust my volt meter. Also I noticed by accident, 1 week ago after I put in alt #3 and even connected the batteries but then it was getting late, so I stopped for the night. later we went out, then came back home and I noticed the radio light was on. the next day the batteries were dead. spent next 2 day re-charging the batts as they were disconnected from truck. Today the truck started fine, lots of bzzing and clicking under dash, but still NO charging, under the drivers battery is the ABS mod , it was clicking 2 times in every 8 seconds before starting truck. No CE light but ABS light been on for bout 6 years, rarely it does go out. I'm sure the truck has parasitic draw / but it's not constant. This alternator problem is new. The truck gets driven about 8 times per yr. to tow 5th whl cmpr. ANY HELP IS APPRECIATED, THANKS GUYS
 

·
Registered
Joined
·
7 Posts
it sounds like you have a short in your plugin for your alternator. i would trace your wires and see if something is burned though. had the same problem your having on my 99 f350 traced the wires and one got hot and melted (was grounding out not let it charge). all i had to do was fix the wire and my problem was solved. it sounds like you have the same problem. i would start there and see where it takes you. hope this helps.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
that seems logical, I was doing some research on the wiring diagram and check this out , The Haynes book {wiring schematic} for a 2000 f250-f350 diesel single alternator setup, differs slightly .Haynes shows the wire in question goes to the instrument cluster, while BBB industries , version show that same wire going to the PCM. Only thing now is to get in there and see which direction this will go, I do thank you for your fix. I will update soon.
 

·
'consent of the governed'
Joined
·
5,771 Posts
I went through 3 alternators and 3 set of batteries 2 winters ago when the mechanic forgot to reconnect the main engine ground after an accident. Insurance paid, dealer fixed? Reconnected ground, problem solved. Good luck
 
1 - 4 of 4 Posts
Top