Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
Hey guy's my buddy has an 08 and was towing a 30' travel trailer this weekend and the CEL light came on. Took it to the dealer and they said it was a back pressure code. He has the MBRP cool dual's with the AFE intake.
The dealer is saying that the exhaust triggered the code but he's had it on for over 10,000 kms. Anyone heard of this or any suggestions? Thanks.:dunno:
 

·
Registered
Joined
·
589 Posts
the afe will trigger an air intake overspeed cel. normally it will only come on during a regen but it will go off. what was the code and why did they blame the exhaust? it should have nothing to do with it.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #3 ·
Not sure of the code but they just said without the muffler, if you can call it a muffler it set this back pressure CEL. I'm going to try and find out the code.
Thanks.
 

·
Registered
Joined
·
3,802 Posts
Not sure of the code but they just said without the muffler, if you can call it a muffler it set this back pressure CEL. I'm going to try and find out the code.
Thanks.
LOL, what a crock of ****...maybe they have never looked at the stock "muffler" its straight thru, so putting a straight pipe exhaust is not gonna change the backpressure.


Its the intake throwing the code.
 

·
Registered
Joined
·
3,802 Posts
Yup take off the AFE and that will fix your problem :nod:
You dont have to take it off...have the code cleared at autozone or something and odds are it wont come back on again....and after you get a tuner it wont come on anyhow...mine never does...I have my AFE on, and am not taking it off.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #7 ·
Yes we are both waiting for the Spartan tune and delete pipe and may-be take the AFE off untill the tuner is released and hopefully comes out soon because these things eat fuel like crazy. Thanks
 

·
Premium Member
Joined
·
17,841 Posts
You dont have to take it off...have the code cleared at autozone or something and odds are it wont come back on again....and after you get a tuner it wont come on anyhow...mine never does...I have my AFE on, and am not taking it off.
It will come back on....when I only had the AFE on it would come back on after 40 or so miles no matter how many times I cleared.....but yes a DPF delete tune will get rid of the problem once and for all...
Yes we are both waiting for the Spartan tune and delete pipe and may-be take the AFE off untill the tuner is released and hopefully comes out soon because these things eat fuel like crazy. Thanks
Good luck, let us know how it goes :icon_ford:
 

·
Registered
Joined
·
132 Posts
I have an afe and the cel just comes on randomly every once in a while . it will go off after like a day usually or sometimes sooner.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #10 ·
Thanks guy's for your info and let's hope Spartan releases the good's soon!!
 
1 - 10 of 10 Posts
Top