Ford Powerstroke Diesel Forum banner

61 - 65 of 65 Posts

·
Registered
Joined
·
482 Posts
Discussion Starter #62
No updates..

I still need to order parts and want to do it all at once.
Tank mods, lift pump and pre filter ect and going to pull the bed off to make life easy and to clean up the frame at the same time.

When I replaced the HPOP I cleaned out the sensor witch was completely clogged (may have broke the sensor) the line was just replaced and still cinda clean but didn't clean it or the manifold so I'll probably do that this weekend.

Been focused on the bronco lately...it's been years sense I dove/enjoyed it and now that I'm so close to getting it finish I just want it done lol :please:

First time I dove it a few weeks ago in 3 years!
I have gone through so much and had to put up with so much bull **** just to get it back from my buddy's ex wife and her $100k lawyers.... it was a pretty emotional experience and just wanted to ball like a baby lol but was having to much fun :scuffy
 

·
Registered
Joined
·
482 Posts
Discussion Starter #63

·
Banned
Joined
·
1,312 Posts
No one has mentioned oil level or condition...

Oil level and condition will make a huge difference on starting and smooth running. Try an oil change with synthetic 5w40 and see what it's like after that. If the truck runs a little better you know your injectors are showing wear.

I was getting to a point where the truck wouldn't start up cold or run properly with 15w40 due to worn injectors.

If the oil level is even slightly low you'll get what seems like major problems too.
 
61 - 65 of 65 Posts
Top