Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
11,152 Posts
Discussion Starter #1
hate to seem so urgent but it kinda is, kinda isn't.
sitttin here in Lubbock in the travel trailer with a truck that can't tow it over 40 miles an hour.
so the story, i was going uphill about 70 when we noticed that there was white smoke coming out the rear right of the truck. checked it and it was oil that had burned off the exhaust pipe cause it was hot. and there was a LOT of oil under the truck all the way to the back. got to where i could check it better off the side of the road and discovered lots of hot fresh oil in the valley. so we limped back a few miles and i pulled off the intake to check my HPO Xover hose. it didn't blow. found out i was about a gallon of oil low. so limped back back to Lubbock and in 40 miles at 40 mph i lost about a quart of oil. so gonna take it to a shop who says it's probably the right side HPO line. checked some info on the ORG and think it might be a HPO Oring.
any other helpful ideas?
 

·
Registered
Joined
·
11,152 Posts
Discussion Starter #2
anyone? help please before eight in the morning
 

·
Registered
Joined
·
11,152 Posts
Discussion Starter #4
thanks dirk
took it in this morning and guy found it was the o ring on the plug on the back of the HPOP. i didn't know there was one there.
but just a half hour of labor. back home
thanks though
 

·
Premium Member
Joined
·
4,448 Posts
Only a gallon. The last one of those i had that was leaking the guy ran till it would start and stall. Added 11 quarts of oil. :doh:
 

·
Premium Member
Joined
·
11,178 Posts

·
Registered
Joined
·
11,152 Posts
Discussion Starter #8
Yeah..


I lost 2 gallons in 2 miles during my last HPO failure.Talk about mess. She leaked oil for 3 months after that. *ANY* time I parked at a angle... leak.
this guy was pretty good. let me watch him to see what he did and even washed out all the oil in the valley. still got a mess under the truck and even oily spots down the right side of the travel trailer
 

·
Registered
Joined
·
1,538 Posts
Exact same thing that happened to me. I'm with dirk on the leaking for several months after.. I still have a leak, it just burns off before it actually get to the ground so I'm not worried.
 

·
scuffs *****
Joined
·
5,270 Posts
Sounds like a flux capacitor to me :dunno:
 
1 - 11 of 11 Posts
Top