Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have a problem,

I have a remanufactured gtp38 for my 7.3 motor that I just got done building. I took the turbo apart to put the BD billet wheel on it and it won't even slide onto the shaft. The shaft is larger than the hole in the wheel. The wheel that was on the turbo is not threaded, it slides on to the shaft then there is a nut that holds it on. I have other 7.3 turbo wheels layin around that I tried with the same result, the hole in the wheel was to small to go on the turbine shaft. Seems like the reman has a larger and different style end on the turbine shaft than the factory garrett unit. Has anyone else ran into this problem? Any input would be greatly appreciated
 

·
Registered
Joined
·
6,107 Posts
thel shaft should be threaded.
ive never seen a stock turbo with a nut to hold it on lol.
i think someone needs to give you a different turbo.

the wheel should thread right on.

post a pic of turbo so we can see
 

·
Registered
Joined
·
24 Posts
you have a chinese turbo. i put one on my 7.3 before i sold it. you will have to get one from the junk yard and rebuild it or buy a new one.. good luck
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thanks for replies guys. I kind of figured I ended up with a cheap Chinese turbo, and i'm pretty sure the guy that sold it to me knew it. None of the bolts that I took out were really tight. they were just kind of "snug". So he probably took it apart to put the wheel on and found the same thing. So he put it back together and sold it to some unsuspecting sucker(myself) without sayin anything. I'll have to run it for now cause its all I got besides an e99 turbo and a full ATS setup that was another craigslist deal I got shafted on. Its all ATS except for the turbo which max's out at 21psi and is screamin like a banshee. Thanks again for the replies
 
1 - 4 of 4 Posts
Top