Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
So i have a a problem with my 96 that has stumped me. I replaced the starter, glow plug relay, and starter solenoid and then i parked the truck. The next day i am ready to drive my truck and it dies...dead battery. Charge the truck up, and its showing that the alternator is not charging. Removed the alternator and checked it...it failed. Got a new one and threw that on thinking that it would fix the problem. Well nope. The alternator gets very hot and is not charging the batteries at all and the truck then dies.

Can some one help me out!
 

·
Registered
Joined
·
17 Posts
Did it run fine when you first bought it? If the batteries are not charging and the new alternator is getting hot i would guess that the wire leaving the alternator may be shorted between the alternator and where it is carrying the charge to which could be either the starter or directly to the batteries
 

·
Registered
Joined
·
122 Posts
Discussion Starter #5
it ran great, had voltage a little past center all the time. Also the main wire that has a nut to hold it into place is good. It goes directly to the starter soleniod on the fender. The wires that are plugged into the voltage reg. look like they have seen better days though.

Do you know where i can get a new set? Also could you take a very close up picture of your starter soleniod on the fender?
 

·
Registered
Joined
·
17 Posts
That could be a good chance thats your problem, not to sure where you could buy them maybe advance, napa or O'Rileys. Sorry i dont have a camera to take a picture for you.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #7
advance and auto suck do not have it. i wish i knew the ford part #.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #8
found it, MOTORCRAFT Part # WPT119

Just ordered it from rock auto for $28 shipped.
 
1 - 8 of 8 Posts
Top