Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
hi i have changed my hpop 6months ago and not driven much whit car,
but now it dosnt have any power again,, and can only idle,, hard to start,,

icp presure goes just above 520 when it starts and sit on 550 on idle,

nothing happends when i press pedal no power nothing,

ipr valve is 14% engine of,, and on idle 95%
is it my hpop again or can it be something else?

why do new one only last months ?

ficm look ok,, something else i should check ?
 

·
Registered
Joined
·
968 Posts
Looks like you have a high pressure oil leak or air in the system. I don't think your HPOP is bad after 6 mo unless you got a dud. You can do an air test to see if the stand pipe or injector o-rings are leaking. Read the links included.

DTS Articles - 6.0L ICP System Leaks

Q: What are normal ICP and IPR values?

A: Cold engine low idle ICP = 806psi IPR 29%
A: Cold engine high idle ICP= 960psi IPR 33%
A: Warm engine low idle ICP= 585psi IPR 24%
A: Warm engine high idle ICP= 735psi IPR 28%
A: If your engine requires a high IRP percentage to get the same or lower ICP you might have an internal high pressure oil leak .

 

·
Registered
Joined
·
183 Posts
Discussion Starter #3
can i have problems whit injector so they dont get up rpm and thats why i get low oil pressure ??

because when i do buzz test,, it buzz 1 time then klick 8 times,, and then buzz 1 time and klick 8 times,, nothing more,,

if i dont remember wrong, it should buzz 8 times,, and click som betwen each buzz ???
 

·
Banned
Joined
·
920 Posts
Low oil psi on the hpop or lpop? I think you might have a dummy plig or busted standpipe oring
 

·
Registered
Joined
·
183 Posts
Discussion Starter #5
i check on icp pressure so mmust be hpop... or something that connects there.

i have build i tool so i can put pressure on icp port. so will try that,,
someone have guide how i close ipr or if i can do it whit AE ?

something else i should check ?

thanks
 

·
Premium Member
Joined
·
6,293 Posts
I think you can command the IPR with the AE software. If you can not you can do it easily.
Fabricate a pigtail for the IPR plug. One pin gets a full 12 volts, the other gets ground.
Do not apply a full 12 volts to the IPR for more than one minute at a time. Allow a minute between the times that you do apply the voltage to allow the IPR to cool.
This sounds as though you will find that the standpipes or a dummy plug is leaking. All are accessible under the valve covers.
 
1 - 6 of 6 Posts
Top