Ford Powerstroke Diesel Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
279 Posts
Blwnsmoke:

Thanks for posting on this issue for our trucks Sir!

FWIW,....I have never had this happen with my 2014, but one of my friends that had a 2012 Ford 6.7 Super Duty 6.7 had it happen to him and it DID leave him on the side of the road having to call a wrecker and tow his truck to the Ford Dealer. As a result of his experience, I went to my Ford Dealer and bought one of those sensors to have as a "spare" JUST IN CASE it happens to my truck.

My Ford Tech said there are like FOUR of those sensors in the exhaust system but the one most prone to failure called "BANK ONE, SENSOR FOUR" which is the one behind the DPF as stated in the "Bloomberg" article by blwnsmoke.
I paid about sixty ($60.00) for that sensor but hopefully I won't have to
use and if I do hopefully the new one will work!:nod:
 

·
Registered
Joined
·
4 Posts
I just took my 13 in for this flash and immediately after leaving the dealer I got a CEL with code P220a. NOx sensor needs changed. Truck ran like a dream before the flash now it's been a week and it's still in the shop.
 

·
Public Enemy #1
Joined
·
133 Posts
I'm sorry I don't trust Ford at all with this. My 2011 shut down in a very bad neighborhood, luckily during the day. This re-flash is sketchy and I am now in control of my truck, Ford will not be dictating when my truck shuts down to comply with some random nazi epa edict. I personally hope a huge f....ing lawsuit opens this crap wide open. Why in the hell do we need so many egt sensors? We all know why and it is crap.....just my .02 cents /end rant.
 

·
Registered
Joined
·
159 Posts
Already had the above flash previously, but ran my VHR this afternoon, to check my oil life monitor rating, also had this notification in the email report

Field Service Actions
Notice # Description
15M02 EXHAUST GAS TEMPERATURE SENSOR EXTENDED COVERAGE
Wondering if this should be changed out now, the engine has been experiencing an occasionally idle hiccup.

Seems I have not seen it warning that the clean cycle is starting in a while, wondering if this sensor is having a problem, though I don't have any codes
 
21 - 25 of 25 Posts
Top