Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
660 Posts
Discussion Starter #1
Guys, you help is needed :thumb:
My buddy just bought a non running 04 6.0 with 297,000 miles cheap. The FICM had to be replaced just to start it. A smaller dealer did that for him. Once running it smoked horribly and they told him it needed head gaskets. I told him to bring it home and we would check it out. Good call on my part because the source of the smoke (was actually steam) was from a leaky egr cooler. We removed the cooler, blocked of the exhaust and re-routed the coolant. Unplugged the egr and off he went. Truck ran OK, not great but no more pressurizing the bottle or smoke/steam. This was two days ago. It didn't have the power of mine but I have a tune. On his way home from work yesterday it seemed to lose more power and took alot of time to get up to speed. For the heck of it I put a canned tune on it from my sct. It ran 100% better but you could feel that something still wasn't right. Probably the best way to describe it is that it feels like my truck when it's not warmed up yet. Isn't missing or anything like that just not smooth. We put it back to stock and it's gutless again.

If the head gaskets were gone wouldn't it be pressureizing the coolant tank?

Any suggesttions are greatly appreciated. I was thinking maybe injectors...
 

·
Registered
Joined
·
660 Posts
Discussion Starter #2
Could it be as simple as a fuel filter change?
Last night we cleaned and re-oiled the K&N filter in the intake.
 

·
Super Moderator
Joined
·
31,730 Posts
That wouldve been the first step. Change the fuel filter and run some fresh fuel and additive through it. When you change the top filter refill the fuel bowl with seafoam. I cant remember did you change the oil as well?
 

·
Registered
Joined
·
660 Posts
Discussion Starter #4
Oil hasn't been changed yet but according to the sticker on the windshield it's about 500 shy of needing it.
 

·
Super Moderator
Joined
·
31,730 Posts
Oil hasn't been changed yet but according to the sticker on the windshield it's about 500 shy of needing it.
Do it especially since the truck sat for so long. Old oil can cause a crapload of problems in a PSD
 

·
Registered
Joined
·
660 Posts
Discussion Starter #6
Found the problem; connector on one of the rear injectors came unplugged :doh:
 

·
Super Moderator
Joined
·
31,730 Posts
1 - 7 of 7 Posts
Top