Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
428 Posts
Discussion Starter #1 (Edited)
FIXED: Realized i never updated this, for future reference for anyone with this issue!

My cables going to one battery the bolts had come loose but yet they were still snug, well snug doesn't cut it with these beasts! Took it to a shop they cut them off put some new ones on tightened down tight and starts like it hadn't in awhile!






Seems like this truck just doesnt like me, went through a big deal last year, stolen, injector cups leaked, new injectors, bad batter, etc. so been great this year... until it got chilly here in tx a couple weeks ago.

Go to start the truck turns over fine, but a click noise constant under the steering wheel somewhere and it WILL NOT fire when this thing clicks. So it was doing it last year and ended up being a bad batter, checked batteries one was 2 3/4 years old and it was 11 at night jumped the truck off (started fine on the jump) and went to walmart changed the batter out (i had to travel back to arlington to school and i was at home when it happened) swapped batteries and bam started back up fine! been doing great until i go out about 20min ago to start it in the apartment parking lot and it does it again, i disconnect my alarm system fuses in case its something to do with it, still does it.

Seems to only do it when its cold, ill see if i can get it started tm afternoon when it warms up a bit.

Ideas? i dont really have many vehicles around here that can attempt to jump me off lol alot of cars and foreign trucks.

So anyways im looking for all ideas and suggestions to the limits that i can do here at least lol probly going to need to drive it an hour home thursday and to houston friday morning.


Thanks!
 

·
Registered
Joined
·
399 Posts
Mine clicks when the batteries are low. I am not for sure, but I do believe the batts should be 12v when off, and 14v ish when running. This is why when you hook a charger up it does fine. Check battery connections also.
 

·
Registered
Joined
·
428 Posts
Discussion Starter #3 (Edited)
So even tho it's turning over something electrical due to low voltage is keeping it from starting when colder? What could cause that? I'll wiggle cables after class!

And what is it in the cab that's clicking??
 

·
Registered
Joined
·
399 Posts
I'm not sure. It sounds like a relay, but I dont know what for. Its under my steering wheel is all I can tell.
 

·
Registered
Joined
·
6,108 Posts
always replace batteries in pairs.

take the old battery out and get it load tested.
 

·
Registered
Joined
·
428 Posts
Discussion Starter #6
Realized i never updated this, for future reference for anyone with this issue!

My cables going to one battery the bolts had come loose but yet they were still snug, well snug doesn't cut it with these beasts! Took it to a shop they cut them off put some new ones on tightened down tight and starts like it hadn't in awhile!
 
1 - 6 of 6 Posts
Top