Ford Powerstroke Diesel Forum banner

1 - 20 of 22 Posts

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #1
Well, wednesday i hooked up my EBPV brake to the throttle. I had the main dash panel off along with the radio. I drove it yesterday and the radio didn't work, i thought that maybe i didn't plug the wires all the way in. Turned out to be the fuse in the panel. I changed the fuse with the correct (5amp), then drove to town. When i started my truck to come back home, smoke started rolling from the dashboard. I took the panel off and one of the wires had the insulation melted off of it. I have no idea what could have caused that, the wires i was messing with wednesday have nothing to do with the wire that melted. It was a black/pink wire. Im friends with a guy at the local dealer, he let me borrow a book that has the entire wiring system of these trucks. The wire goes to the radio, and to the headlight switch. Im guessing its the illumination, but i haven't looked into it that much yet.

DO NOT USE HARBOR FREIGHT FUSES!!!!!!!!! that is what i replaced it with, and the wire melted and the fuse was still intact.
 

·
Registered
Joined
·
2,545 Posts
DO NOT USE HARBOR FREIGHT FUSES!!!!!!!!! that is what i replaced it with, and the wire melted and the fuse was still intact.

cant tell you how many times ive heard that one, but i have no idea what happened i melted a set of wires to the neon lights i have in the cab but i dont know what caused thaat one either, good thing it didnt go too bad!
 

·
Premium Member
Joined
·
19,112 Posts
Yep, there was a pretty massive recall on those cheap fuses.... Glad it didn't get out of control!
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #6
Yep, there was a pretty massive recall on those cheap fuses.... Glad it didn't get out of control!
Yeah, i found out about the recall when i was looking on their website to find a number to call and ream someones a$$ out. Unfortunately i found out about it AFTER i melted the damn wire. :mad:
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #7
I checked the price of a new wiring harness. Its almost $500. I will be talking to someone high in harbor freight's management. I'll keep you guys posted on how that turns out.
 

·
Premium Member
Joined
·
19,112 Posts
I'm very surprised that those weren't pulled from the shelves. Good luck, bud. Keep us posted.
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #9
I think they probably were, but i bought them a few month ago.

Heres an update on my situation. I called them this morning, they asked me a bunch of info, when it happened, where it happened, who was with me, and a bunch of personal info, name, address, phone number, etc. They said they will make a report with all the info and forward it to the legal dept. and they will get back with me within a week. The right thing for them to do would be to pay for the repair, and it kinda looks like they are gonna. We'll see. I'll keep y'all informed.:thumb:
 

·
Registered
Joined
·
1,257 Posts
Hmmm, sounds like a TW chip to me :thumb:
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #11
Hmmm, sounds like a TW chip to me :thumb:
Oh yeah... if they say they're gonna pay for it, im gonna get the highest estimate i can find, then do it myself and take the extra cash, and yeah, probably send it to Tony.:burnout::happydance:
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #12
Well, i said id keep y'all updated, so here is my update. They asked me to send in 2 estimates and a statement of what happened. I did, and after 2 weeks they finally reviewed it, and today told me their offer. Before i say what the offer was let me back up a bit. One of the estimates was about $1400 and the other was about $1900. They offered me $500.:hehe: :umno: I told them that was ridiculous. So now they want me to send a rebuttal and explain why i wont accept their offer.:doh:

Yeah, like im actually gonna take $500 for a repair that is estimated nearly $2000. Thats damn near insulting.
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #14

·
Powerstroke Junkie
Joined
·
8,308 Posts
That fuse didn't blow and because of this your harness has been damaged, so you still have a problem there. I believe that is what they are looking at, called it the contributing factor. Did you ever figure out what caused the wire to melt in the first place? Sounds like you did something wrong while you were in there, and by the fuse not blowing you have some damage to take care of, just make sure you find the real source of the problem.

NCH
 

·
Registered
Joined
·
214 Posts
That fuse didn't blow and because of this your harness has been damaged, so you still have a problem there. I believe that is what they are looking at, called it the contributing factor. Did you ever figure out what caused the wire to melt in the first place? Sounds like you did something wrong while you were in there, and by the fuse not blowing you have some damage to take care of, just make sure you find the real source of the problem.

NCH

There is a recall on the fuse he used. I hardly think he did anything wrong.

SAFETY RECALL
 

·
Powerstroke Junkie
Joined
·
8,308 Posts
The fuse failed to blow when a excessive flow of amps went through the wire, which caused a wire downstream to melt, the fuse didn't cause higher amperage so I beg to differ, there is another problem here!! Fuses don't add or increase amperage.

NCH
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #18
The fuse failed to blow when a excessive flow of amps went through the wire, which caused a wire downstream to melt, the fuse didn't cause higher amperage so I beg to differ, there is another problem here!! Fuses don't add or increase amperage.

NCH
A fuse is supposed to blow when the amps get too high, which it didn't, i know exactly what happened, when i installed my stereo, there was about a 1/8" of wire that i missed with the electrical tape, which shorted out on a piece of metal in the dash. The fuse should have blown. Had the fuse blown there would have been no damage. I can prove that too because the original fuse did blow, but the Harbor Freight one didn't.
 

·
Powerstroke Junkie
Joined
·
8,308 Posts
I am glad you discovered the source of the problem. That is what I was getting at, this problem didn't happen because of a faulty fuse, there was another problem and the fact that the fuse didn't react like it should did cause the damage. Glad you understood what I meant!!

NCH
 

·
PMR = JUNK
Joined
·
11,244 Posts
Discussion Starter #20
I am glad you discovered the source of the problem. That is what I was getting at, this problem didn't happen because of a faulty fuse, there was another problem and the fact that the fuse didn't react like it should did cause the damage. Glad you understood what I meant!!

NCH

Yep:nod:. I thought we were on the same page, i just explained it a bit different the last time just to make sure.
 
1 - 20 of 22 Posts
Top