Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
I have a 02 F-350 with the 7.3 in it, about a year ago I installed a air dog AD-165 fuel pump. It's been running fine, now it has started blowing the 20 amp inline fuse. Replacing the fuse last's about 2-3 days then it blow's again. I also changed the water seperator and fuel filter. The pump sounds the same as when we installed it, no noticible change in sound. Any ideas what might be causing the fues to blow ? Thanks
 

·
Premium Member
Joined
·
5,682 Posts
The motors done. You're gonna have to get a replacement. Do you have a fuel pressure gauge? I'd hate to see what pressure your motor is getting.

With the new motor, upgrade the wiring from the power source to the motor. The AirDog harness wiring is too small, and doesn't provide enough voltage to keep the motor happy.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
The motors done. You're gonna have to get a replacement. Do you have a fuel pressure gauge? I'd hate to see what pressure your motor is getting.

With the new motor, upgrade the wiring from the power source to the motor. The AirDog harness wiring is too small, and doesn't provide enough voltage to keep the motor happy.
No fuel pressure gauge, That sucks that the motor went so quick. You pay a lot you would expect it to last longer than that. Guess I will have to contact Air Dog and see if they sell just the motor.
 

·
Premium Member
Joined
·
5,682 Posts
No fuel pressure gauge, That sucks that the motor went so quick. You pay a lot you would expect it to last longer than that. Guess I will have to contact Air Dog and see if they sell just the motor.
Trust me, I know.

It should be covered under the lifetime warranty.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #6
I did not know they had a lifetime warranty ! I found the receipt and called AirDog, spoke to Josh. All I had to do was fax the receipt and they are sending out the new part. Thanks guys !
 

·
Banned
Joined
·
5,630 Posts
Wow thats great to hear... stand up company!
 

·
Registered
Joined
·
77 Posts
too bad to hear about the pump.
However Glad to hear someone else is having problems with their air dog. I bought the Raptor 150 last month. Only put out 40psi w fully turned in regulator. They sent me a new one happily. This one puts out 57psi fully turned in. Drops to 54 at full throttle. Lifetime warranty doesnt mean sweet [email protected]#$ all when your truck is down for 20 days in the middle of moving and not making $$$$. And your replacing pumps every week.

going to try the wiring upgrade. good link thanks!
 
1 - 9 of 9 Posts
Top