Ford Powerstroke Diesel Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Is anyone running this intake? Ptp has it on sale for 322. I'm thinking on pulling the trigger. Any help is appreciated . I planned on the s&b but I like the looks of the afe better and it filtrates a minuscule amount better.
 

·
Registered
Joined
·
104 Posts
I'm running the stage 2 afe on my 7.3 and I love it. I have the dry filter and I got mine for 329 included shipping.


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
What kind of gains will I see? Mpg,EGR,intake temp, sound,spool up, throttle response?
 

·
Registered
Joined
·
994 Posts
I have it. No complaints here.


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
4,329 Posts
I have it but with the dry filter. The only difference I have heard people say is afe tends to be louder and let more turbo noise out which I liked so that's what swayed my vote.
 

·
Registered
Joined
·
1,763 Posts
Running it here as well.
 

·
Registered
Joined
·
1,763 Posts

·
Registered
Joined
·
1,378 Posts
I gained 3-4 MPGs and I really can hear my turbo now


Sent from my iPhone using Autoguide
You must have done some other upgrades at the same time to get an improvement in mileage that high.
 

·
Registered
Joined
·
104 Posts
The usually the up grade is 2-3mpgs if that sometimes... I have no other performance upgrade but I have a cervinis ram air hood on my truck. It's not hooked up it just dumps more cold air onto my engine..


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
38 Posts
Discussion Starter #12
I got the efi in yesterday, put it on this evening, looks good when in good and my truck sounds great. seems to have a little better throttle response, thanks guys. O and thanks PTP! Picked it up for $322.96 and free shiping. Ordered it wed and it was here when I got home friday now thats what I call service.
 

·
Registered
Joined
·
1,763 Posts
Good deal! But what is this efi you put on?

I re-read the thread, lol I figure you meant aFe vs efi!
 

·
Registered
Joined
·
38 Posts
Discussion Starter #14
Whoops my bad yes it's afe lol thought I was in a government motors turd
 

·
Registered
Joined
·
50 Posts
I have it, and i am not a huge fan. I had to replace the one smaller boot for the turbo, it almost looked like a dry rot and was cracked almost in half. The larger boot is doing the same but is still solid last I checked. The first boot was worn in less than a year. I say whatever they are making them out of cant handle the underhood heat or the oil that gets in em.
 

·
Registered
Joined
·
994 Posts
I have it, and i am not a huge fan. I had to replace the one smaller boot for the turbo, it almost looked like a dry rot and was cracked almost in half. The larger boot is doing the same but is still solid last I checked. The first boot was worn in less than a year. I say whatever they are making them out of cant handle the underhood heat or the oil that gets in em.
Weird you say that...I took the clamp off of the boot at my turbo/CAI connection and the metal threads had melted into the boot (not all the way through, but definitely left the pattern sunk into it.) I don't overtighten my clamps, and I don't see any temps over 1100 deg but maybe once a month (i.e. i ain't gunning it all the time...i drive it like i am supposed to!)

I'm anxious to hear if anyone else is experiencing this...great thread!

:icon_ford:
 

·
Registered
Joined
·
1,763 Posts
Ill have to take a closer look this week. Mines been on for just under a year I think.
 
1 - 17 of 17 Posts
Top