Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
322 Posts
Discussion Starter · #1 ·
Yesterday while towing a Durango my Ac started blowing really warm air. I figure with the trailer it weighed about 6,000lbs so I put on my unlimited tow from Matt, thought SRL would be pretty hot tune to pull that much. The ambient temp was about 80 the whole time. My coolant temp was about 196-198 and my oil temp was around 200-204. It was about a 1 and a half hour trip and it worked for the first 15 minutes. After dropping the Durango off and driving the 1 and a half hour back it worked the whole time. Even turned it down as it was pretty cold inside the cab. Ive never had any problems with the Ac and I'm kinda stumped. Did the tow tune make the fan clutch do more and affect the Ac clutch? Really don't have any ideas but I'm about to go on an 8hr trip with 6 ppl in my truck and need the Ac to work. Thanks for any ideas.


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
60 Posts
I've had the same problem with my 05 all summer. Seems like if I shut the air off for a minute then turn it back on it starts working. No clue why. I am running Matt's srl+.
 

·
Registered
Joined
·
2,489 Posts
I've had the same problem with my 05 all summer. Seems like if I shut the air off for a minute then turn it back on it starts working. No clue why. I am running Matt's srl+.
Does it blow really cold for a while then stop? If thats the case your AC is not charged correctly (I believe its undercharged).
 

·
Registered
Joined
·
2,489 Posts
Sounds like the condensor freezes up. I would go to a shop (unless you have AC manifold gauges) and see what they say. I believe your undercharged.
 

·
Registered
Joined
·
14 Posts
99 doing it too

My 99 is doing the same thing. I've found that if I stand on the throttle the AC starts to work again. i don't think it's freezing up the condenser because it comes and goes very frequently. Please let me know what you find. btw... i have manifold gauges and the system is charge to spec.
 

·
Premium Member
Joined
·
322 Posts
Discussion Starter · #10 ·
Well in the last week I drove my truck about 22 hours. The Ac was on for at least 20 hours and it worked great the whole time. Guess if it's not broke don't fix it. Still don't know what caused it the first time. When it happened my windshield fogged up really bad at the same time, not sure what that meant if that's a clue to anyone.


Sent from my Autoguide iPhone app
 
1 - 10 of 10 Posts
Top