Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I'm having a strange issue with the A/C blower motor. Whether it's in Auto mode or manually adjusting the speed, the motor erratically changes speeds all the time.

Any thoughts on what the problem is?:dunno:

Thanks,

Dave
 

·
Registered
Joined
·
994 Posts
It's most likely your actuator. There's two components that run the speed. I had the same issue and was going to replace the main unit and the actuator, but I had to disconnect my batteries for something and it corrected itself. It's behind the passenger glove box--easy fix. Buying from Ford was like $150 for both parts. From Rock Auto, much cheaper. Hope that helps.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks, I'll check out Rock Auto. I had both Actuators replaced back in May of 2011. Ughh..

Dave
 

·
Registered
Joined
·
994 Posts
man i've heard guys with multiple problems and none at all. sorry for your troubles. electric components are a nightmare...where i appreciate the technological advancements, wish they were easier to fix when they break...shoot just wish the diagnostic was more simple! I told my pops the other day who still drives his single cab with no A/C that I will probably never by a newer truck because of the lack of ability to work on 'em. It's awful sad really.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Yeah, It's a pain. I'm also going to get the blower motor resistor as well. Just ordered the parts from Rock Auto. If this doesn't work, I'll be forced back to the dealer.

My satellite also stopped working. Now I get a "SAT FAULT" reading when I try to use it. Dealer wants ~$800 to fix it. I don't need satellite that bad.
 
1 - 5 of 5 Posts
Top